Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511740 - fail to install rhel-(alt-)7.5 on s390x,ppc64 with error /dev/root does not exist
Summary: fail to install rhel-(alt-)7.5 on s390x,ppc64 with error /dev/root does not e...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut
Version: 7.5-Alt
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-10 02:40 UTC by Jianlin Shi
Modified: 2017-12-07 14:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-07 14:34:21 UTC


Attachments (Terms of Use)

Description Jianlin Shi 2017-11-10 02:40:15 UTC
Description of problem:
fail to install rhel-alt-7.5 on s390x with error /dev/root does not exist

Version-Release number of selected component (if applicable):
RHEL-ALT-7.5-20171106.1

How reproducible:


Steps to Reproduce:
1. install RHEL-ALT-7.5-20171106.1
2.
3.

Actual results:
fail

Expected results:
pass

Additional info:


[  362.068641] dracut-initqueue[760]: Warning: dracut-initqueue timeout - starti 
ng timeout scripts                                                               
[  362.638619] dracut-initqueue[760]: Warning: dracut-initqueue timeout - starti 
ng timeout scripts                                                               
[  363.218689] dracut-initqueue[760]: Warning: dracut-initqueue timeout - starti 
ng timeout scripts                                                               
[  363.778487] dracut-initqueue[760]: Warning: dracut-initqueue timeout - starti 
ng timeout scripts                                                               
[  363.778668] dracut-initqueue[760]: Warning: Could not boot.                   
[  363.780212] dracut-initqueue[760]: Warning: /dev/root does not exist          
         Starting Dracut Emergency Shell...                                      
Warning: /dev/root does not exist                    



job: https://beaker.engineering.redhat.com/recipes/4441775#task63677057
console log : http://beaker-archive.app.eng.bos.redhat.com/beaker-logs/2017/11/21339/2133978/4441775/console.log

Comment 1 Lukáš Nykrýn 2017-11-13 11:35:28 UTC
From the logs it looks like a network issues. Are you able to reproduce this?

Comment 2 Jianlin Shi 2017-11-14 07:24:03 UTC
(In reply to Lukáš Nykrýn from comment #1)
> From the logs it looks like a network issues. Are you able to reproduce this?

I'm trying to reserve one s390x system to reproduce, but no system is available yet.

Comment 3 Jianlin Shi 2017-11-15 00:49:40 UTC
I installed RHEL-ALT-20171106.1 on the same system as description successfully.
https://beaker.engineering.redhat.com/jobs/2145023

But I can't log in the system with ssh, and ping failed either.

The failure in description may also caused by the network issue. so how can this be solved?

Comment 4 Jianlin Shi 2017-11-15 01:38:29 UTC
https://beaker.engineering.redhat.com/jobs/2143853

BTW, this s390x system can be accessed through ssh.

Comment 5 Jianlin Shi 2017-11-16 00:41:52 UTC
the problem happened again: https://beaker.engineering.redhat.com/recipes/4465701#task63938339

why does the problem happen so frequently? Almost all my jobs on S390x failed because installation failed.

Comment 6 Tomas Dolezal 2017-12-07 13:53:55 UTC
Also on non-alt compose, ppc64: RHEL-7.5-20171130.0
ref. https://beaker.engineering.redhat.com/recipes/4557569#task65061425

Comment 8 Lukáš Nykrýn 2017-12-07 14:33:07 UTC
(In reply to Tomas Dolezal from comment #6)
> Also on non-alt compose, ppc64: RHEL-7.5-20171130.0
> ref. https://beaker.engineering.redhat.com/recipes/4557569#task65061425

[   41.331372] dracut-initqueue[798]: curl: (23) Failed writing body (2664 != 2896) 

Does not look like a dracut issue, maybe you have run out of memory?

Comment 9 Lukáš Nykrýn 2017-12-07 14:34:21 UTC
All of these issues looks like a problem with infrastructure, nothing to do in dracut.


Note You need to log in before you can comment on or make changes to this bug.