Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511693 - Server Software Selection screen shows Everything
Summary: Server Software Selection screen shows Everything
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-modular-release
Version: 27
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Stephen Gallagher
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ModularServer27GA
TreeView+ depends on / blocked
 
Reported: 2017-11-09 21:41 UTC by Paul Whalen
Modified: 2018-01-15 19:17 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-15 19:17:33 UTC


Attachments (Terms of Use)
Modular server software selections (deleted)
2017-11-09 21:42 UTC, Paul Whalen
no flags Details
F27 Classic Software Selections (deleted)
2017-11-09 21:43 UTC, Paul Whalen
no flags Details

Description Paul Whalen 2017-11-09 21:41:38 UTC
Description of problem:
Installing Fedora-Modular-27-20171108.2, all software is selectable in the software selection screen rather than limited to just server options.

There is no failure or error when selected software is missing.

Version-Release number of selected component (if applicable):
Fedora-Modular-27-20171108.2

Comment 1 Paul Whalen 2017-11-09 21:42:16 UTC
Created attachment 1350152 [details]
Modular server software selections

Comment 2 Paul Whalen 2017-11-09 21:43:18 UTC
Created attachment 1350153 [details]
F27 Classic Software Selections

Comment 3 Stephen Gallagher 2017-11-13 13:07:06 UTC
The situation here is caused by the fact that we are dropping the complete comps.xml file into the compose tree and not modifying it to trim it down to only the content available on the media (the way that the traditional compose does it).

We need to do one of the following:
1) Figure out how this is done automatically in the traditional media and copy that
2) Manually trim the comps file to match what we're producing.

Obviously, 1) is preferable.

CCing some people who may know a thing or two about it.

Comment 4 Stephen Gallagher 2017-11-17 16:08:42 UTC
Self-assigning.


Note You need to log in before you can comment on or make changes to this bug.