Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511682 - Quota error when adding a group to a Project using Horizon
Summary: Quota error when adding a group to a Project using Horizon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Radomir Dopieralski
QA Contact: Beth Elwell
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-09 20:50 UTC by David Peacock
Modified: 2018-06-27 13:39 UTC (History)
6 users (show)

Fixed In Version: python-django-horizon-13.0.1-0.20180323102048.4dd4ef0.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:39:00 UTC


Attachments (Terms of Use)
Horizon error screenshot (deleted)
2017-11-09 20:50 UTC, David Peacock
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:39:48 UTC
OpenStack gerrit 510188 None master: MERGED horizon: Correct quota usage check for instances (Iee06bc1c8ccd50f595f4cb274f956c13495c8494) 2018-03-29 16:28:50 UTC

Description David Peacock 2017-11-09 20:50:03 UTC
Created attachment 1350110 [details]
Horizon error screenshot

Description of problem:

Using Horizon, customer encounters the following quota error.  However, doing the same thing through the CLI succeeds.

Version-Release number of selected component (if applicable):

RHOSP9

How reproducible:

100%

Actual results:

Project is not adding, with erroneous quota error as attached in screenshot.

Expected results:

Project is added successfully.

Additional info:

As stated, there is no problem through CLI, so this looks like Horizon only.

Comment 1 Beth Elwell 2017-12-11 14:40:18 UTC
Based on the logs, is the cause of this the same as https://bugzilla.redhat.com/show_bug.cgi?id=1522705 ? If so we will fix it there and close as duplicate, if not, please provide the CLI logs so that we can compare what quotas are being shown.

Comment 4 Marc Methot 2017-12-11 19:42:54 UTC
@Beth

The error msg is indeed the same (differs only in values), however it's hit when adding a group to a project not simply altering the quota as in the other bug.
Not sure I would put it all in the same pile.

As to which cli logs do you require? Something like bellow?
~~~
source admin.rc
openstack role add --debug --group $g_uuid --project $p_uuid user
~~~
* I have requested this from the cu in pre-emption.

Also note that the CLI commands does succeed.


Cheers,
-Marc

Comment 5 Radomir Dopieralski 2017-12-13 09:42:30 UTC
It would be interesting to see the quotas for the project being modified and for the user's default project — as displayed by the CLI and as displayed by Horizon.

Comment 6 Radomir Dopieralski 2017-12-19 11:14:42 UTC
After looking at the code, I can only find one place where this error message is used, and it is now fixed in Queens by https://review.openstack.org/510188

Comment 11 Beth Elwell 2018-06-20 08:43:08 UTC
This is now fixed by the linked review and I can confirm this error is fixed.

Comment 13 errata-xmlrpc 2018-06-27 13:39:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.