Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511638 - Display ordering widget not working
Summary: Display ordering widget not working
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: https://fedoraproject.org/wiki/Common...
: 1513357 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-09 18:48 UTC by Patrick Uiterwijk
Modified: 2017-11-21 23:31 UTC (History)
18 users (show)

Fixed In Version: control-center-3.26.2-2.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-21 23:31:58 UTC


Attachments (Terms of Use)
Screencast (deleted)
2017-11-09 18:48 UTC, Patrick Uiterwijk
no flags Details
Screencast where it finally works (deleted)
2017-11-09 18:50 UTC, Patrick Uiterwijk
no flags Details

Description Patrick Uiterwijk 2017-11-09 18:48:23 UTC
Created attachment 1350063 [details]
Screencast

Description of problem:
The display widget in Gnome 3.26 does not reliably allow displays to be dragged around.

Version-Release number of selected component (if applicable):
gnome-shell-3.26.1-1.fc27.x86_64

How reproducible:
Mostly consistent, sometimes it randomly works.

Steps to Reproduce:
1. Have multiple monitors
2. Open display settings
3. Try to move displays around

Actual results:
Be unable to drag monitors around.

Expected results:
Be able to drag monitors around and change the display ordering.

Additional info:
Screencast attached.

Comment 1 Patrick Uiterwijk 2017-11-09 18:50:49 UTC
Created attachment 1350091 [details]
Screencast where it finally works

Comment 2 Adam Williamson 2017-11-09 19:07:05 UTC
kparal reported that he's run into this before and is quite familiar with it. It apparently affects systems with three or more displays, even if one is disabled: a typical affected configuration is a laptop with two external displays, even if the laptop display is turned off.

Marking CommonBugs, it would be good to document this for F27, and explain how to 'jiggle the boxes' to make it work if possible.

Comment 3 Adam Williamson 2017-11-09 19:07:42 UTC
nirik notes this may be related to a major upstream rework of related code, https://bugzilla.gnome.org/show_bug.cgi?id=777732 .

Comment 4 Patrick Uiterwijk 2017-11-09 19:09:37 UTC
Background info: this is with two external (fullHD) monitors, and a closed laptop lid.

Comment 5 Rui Matos 2017-11-14 10:19:54 UTC
Can you test this scratch build https://koji.fedoraproject.org/koji/taskinfo?taskID=23117546 ?

Comment 6 Kamil Páral 2017-11-14 12:18:52 UTC
(In reply to Rui Matos from comment #5)
> Can you test this scratch build
> https://koji.fedoraproject.org/koji/taskinfo?taskID=23117546 ?

No change, still broken here (two external monitors and a laptop lid closed). Exactly the same behavior as in Patrick's video.

Comment 7 Rui Matos 2017-11-14 16:29:56 UTC
(In reply to Kamil Páral from comment #6)
> No change, still broken here (two external monitors and a laptop lid
> closed). Exactly the same behavior as in Patrick's video.

Thanks. Can you test https://koji.fedoraproject.org/koji/taskinfo?taskID=23123071 ? I believe this one should finally fix it.

Comment 8 Kamil Páral 2017-11-15 09:33:39 UTC
(In reply to Rui Matos from comment #7)
> Thanks. Can you test
> https://koji.fedoraproject.org/koji/taskinfo?taskID=23123071 ? I believe
> this one should finally fix it.

Yes, that finally works :) Thanks.

Comment 9 Paolo Antinori 2017-11-15 10:30:59 UTC
*** Bug 1513357 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2017-11-15 14:46:59 UTC
control-center-3.26.2-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6d66333885

Comment 11 Fedora Update System 2017-11-15 23:53:34 UTC
control-center-3.26.2-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6d66333885

Comment 12 Fedora Update System 2017-11-21 23:31:58 UTC
control-center-3.26.2-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.