Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511576 - fs.go:359] Stat fs failed. Error: no such file or directory
Summary: fs.go:359] Stat fs failed. Error: no such file or directory
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod
Version: 3.6.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.9.0
Assignee: Seth Jennings
QA Contact: DeShuai Ma
URL:
Whiteboard:
: 1512714 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-09 15:33 UTC by Eric Paris
Modified: 2018-03-28 14:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-03-28 14:12:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0489 None None None 2018-03-28 14:12:37 UTC

Description Eric Paris 2017-11-09 15:33:02 UTC
I see a bunch of these messages, but they don't tell me what to do. Do they matter? Is there something to fix?

fs.go:359] Stat fs failed. Error: no such file or directory

# rpm -q atomic-openshift-node
atomic-openshift-node-3.6.173.0.5-1.git.0.f30b99e.el7.x86_64

# journalctl --since=-30m | grep 'Stat fs failed.' | wc -l
1573

Comment 1 Seth Jennings 2017-11-09 15:49:12 UTC
Comes from here
https://github.com/google/cadvisor/blob/master/fs/fs.go#L418

Basically the syscall.Statfs() call that getVfsStats() calls returns this error.  Probably in response to a failed/terminated container.

Do you see this recurring over and over for the same path?  Or just one or two times per path?

If just one or two times, then this is log spam and should likely be reduced from Error to V(3).

Comment 2 Eric Paris 2017-11-09 15:52:23 UTC
Someone will need to dig a bit. For example on
starter-us-east-1-node-compute-d9c25
I see that message 1500 times in 30 minutes. And I have no idea what the path is. It isn't in the log...

Comment 3 Tomas Smetana 2017-12-11 10:21:52 UTC
*** Bug 1512714 has been marked as a duplicate of this bug. ***

Comment 4 Tomas Smetana 2017-12-11 10:22:23 UTC
Seems like this was fixed with https://github.com/kubernetes/kubernetes/pull/17883

Comment 5 Seth Jennings 2017-12-11 19:04:43 UTC
Tomas, which commit in cadvisor fixed this?

Comment 6 Seth Jennings 2018-01-19 02:52:16 UTC
Upstream cadvisor:
https://github.com/google/cadvisor/pull/1847

Origin PR:
https://github.com/openshift/origin/pull/18181

Comment 8 weiwei jiang 2018-01-23 09:01:33 UTC
Checked with v3.9.0-0.22.0, and this issue has been fixed.

# journalctl --since=-30m | grep 'Stat fs failed.' | wc -l
0

Comment 11 errata-xmlrpc 2018-03-28 14:12:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0489


Note You need to log in before you can comment on or make changes to this bug.