Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511574 - With long builds the buildstatus polling simply exists after a while
Summary: With long builds the buildstatus polling simply exists after a while
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Copr
Classification: Community
Component: cli
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: clime
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-09 15:22 UTC by Rudolf Kastl
Modified: 2018-01-17 19:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-17 19:51:19 UTC


Attachments (Terms of Use)

Description Rudolf Kastl 2017-11-09 15:22:51 UTC
Description of problem:
When running long builds with copr-cli... at some point the client will not be able to pull the status anymore and exists.

Example:

Uploading package /home/rkastl/rpmbuild/SRPMS/llvm-6.0.0-0.1.r317781.fc27.src.rpm
100% |################################| 24.6MB 660kB/s eta 0:00:00
Build was added to llvm:
  https://copr.fedorainfracloud.org/coprs/build/660133/
Created builds: 660133
Watching build(s): (this may be safely interrupted)
  13:31:06 Build 660133: importing
  13:31:37 Build 660133: pending
  13:49:26 Build 660133: running

Something went wrong:
Error: Connection error GET https://copr.fedorainfracloud.org/api/coprs/build/660133/
Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. start a long running build with copr-cli
2. watch it fail to poll
3. client exists.


Actual results:
client exits

Expected results:
client continues to succesfully poll

Additional info:
NOTE: it happens 100% of the times as of recently. At first i thought it might be an issue with the net connection on my side. I tried in different environments and I also made sure that the net connection is not interrupted while the build was going on. Did anything change that affects that behaviour? 

Additionally i want to add that i am not sure if it is a client or server issue at that point.

Comment 1 clime 2017-11-24 08:41:41 UTC
I have tried it and it run for a few hours without problems - polling wasn't interrupted. I think the the culprit is high load on copr-frontend server that recently started to occur. copr-frontend occasionally stops responding and that might be the case. I don't think there is anything in the code that would cause the interrupts.

Comment 2 clime 2018-01-04 09:09:40 UTC
Hello, I have made the following update in httpd configuration on copr-frontend that should hopefully resolve the issue:

https://infrastructure.fedoraproject.org/cgit/ansible.git/commit/?id=7dc96d992ab35cf7f58c95bfe11eba5bfcd236cf

If not, probably further lowering maximum-requests value for each wsgi daemon process might help. Let me know if you encounter any further problems.

Comment 3 clime 2018-01-17 19:51:19 UTC
I think, this should be resolved now. Sorry for the problems.


Note You need to log in before you can comment on or make changes to this bug.