Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511562 - wget-1.19.2-1.fc26.x86_64 segfaults in http.c:3715 when calling strchr()
Summary: wget-1.19.2-1.fc26.x86_64 segfaults in http.c:3715 when calling strchr()
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wget
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomáš Hozza 🤓
QA Contact: Fedora Extras Quality Assurance
URL: http://savannah.gnu.org/bugs/?52349
Whiteboard:
: 1515931 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-09 15:03 UTC by Petr Pisar
Modified: 2017-12-12 13:43 UTC (History)
4 users (show)

Fixed In Version: wget-1.19.2-2.fc27 wget-1.19.2-2.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-12 11:26:06 UTC


Attachments (Terms of Use)

Description Petr Pisar 2017-11-09 15:03:55 UTC
$ wget https://jplesnik.fedorapeople.org/modules/swig.yaml
--2017-11-09 15:51:10--  https://jplesnik.fedorapeople.org/modules/swig.yaml
Resolving jplesnik.fedorapeople.org (jplesnik.fedorapeople.org)... 2610:28:3090:3001:5054:ff:fea7:9474, 152.19.134.199
Connecting to jplesnik.fedorapeople.org (jplesnik.fedorapeople.org)|2610:28:3090:3001:5054:ff:fea7:9474|:443... failed: Connection refused.
Connecting to jplesnik.fedorapeople.org (jplesnik.fedorapeople.org)|152.19.134.199|:443... connected.
HTTP request sent, awaiting response... 200 OK
Segmentation fault (core dumped)

$ rpm -q wget
wget-1.19.2-1.fc26.x86_64

This does not happen with wget-1.19.1-3.fc26.x86_64.

Backtrace:

Program received signal SIGSEGV, Segmentation fault.
__strchr_sse2 () at ../sysdeps/x86_64/strchr.S:32
32              movdqu  (%rdi), %xmm0

(gdb) bt full
#0  __strchr_sse2 () at ../sysdeps/x86_64/strchr.S:32
No locals.
#1  0x000055555557d1a6 in gethttp (u=u@entry=0x555555803170, original_url=original_url@entry=0x555555803170, hs=hs@entry=0x7fffffffdc50, dt=dt@entry=0x7fffffffe060, 
    proxy=proxy@entry=0x0, iri=iri@entry=0x555555803140, count=1) at http.c:3715
        p = <optimized out>
        req = 0x555555973bb0
        type = 0x0
        user = 0x0
        passwd = 0x0
        proxyauth = <optimized out>
        statcode = <optimized out>
        write_error = <optimized out>
        contlen = 742
        contrange = 0
        conn = <optimized out>
        fp = <optimized out>
        err = <optimized out>
        retval = <optimized out>
        hsts_params = <optimized out>
        max_age = <optimized out>
        include_subdomains = <optimized out>
        sock = <optimized out>
        auth_finished = false
        basic_auth_finished = false
        ntlm_seen = false
        using_ssl = <optimized out>
        head_only = false
        cond_get = false
        metalink = false
        head = <optimized out>
        resp = 0x555555c111c0
        hdrval = "gzip\000Alive\000UUU\000\000\021e~UUU\000\000\000\345\270\366\377\177\000\000\000\332\377\377\377\177\000\000M\000\000\000\000\000\000\000\000\244\270\366\377\177\000\000\000\345\270\366\377\177\000\000\000\244\270\366\377\177\000\000\035\377\202\366\377\177\000\000\200", '\000' <repeats 15 times>, "\200\000\000\000\000\000\000\000/'XUUU\000\000\300\332\377\377\377\177\000\000\t)XUUU\000\000\000\000\000\000\000\000\000\000\021\000\000\000\000\000\000\001--2017-11-09 15:46:00--  https://jplesnik.fedorapeople.o"...
        message = 0x5555559347b0 "OK"
        warc_enabled = false
        warc_tmp = <optimized out>
        warc_timestamp_str = "\000\000\000\000\000\000\000\000\000F\266\263\374Yt\377\000\345\270\366\377"
        warc_request_uuid = "\000\345\270\366\377\177\000\000M\000\000\000\000\000\000\000h\r\000\000\000\000\000\000\000\332\377\377\377\177\000\000\300\230\270\366\377\177\000\000\237\316\203\366\377\177\000"
        warc_ip = 0x0
        warc_payload_offset = <optimized out>
        keep_alive = true
        chunked_transfer_encoding = false
        inhibit_keep_alive = <optimized out>
        body_data_size = <optimized out>
#2  0x000055555557e42d in http_loop (u=u@entry=0x555555803170, original_url=original_url@entry=0x555555803170, newloc=newloc@entry=0x7fffffffdf68, 
    local_file=local_file@entry=0x7fffffffdf70, referer=referer@entry=0x0, dt=dt@entry=0x7fffffffe060, proxy=0x0, iri=0x555555803140) at http.c:4329
[...]

Comment 1 Petr Pisar 2017-12-08 15:29:07 UTC
*** Bug 1515931 has been marked as a duplicate of this bug. ***

Comment 2 Petr Pisar 2017-12-08 15:30:26 UTC
*** Bug 1516504 has been marked as a duplicate of this bug. ***

Comment 3 Petr Pisar 2017-12-08 16:02:04 UTC
This was reported to upstream <http://savannah.gnu.org/bugs/?52349> and fixed in upstream with:

commit 973c26ed7d51052a7b6e120ed1b84e47266667e1 (HEAD, refs/bisect/bad)
Author: Darshit Shah <darnir@gnu.org>
Date:   Mon Nov 6 10:09:03 2017 +0100

    Fix Segfault due to derefencing null ptr
    
    * src/http.c(gethttp): When Encoding is gzip, ensure that the
    Content-Type Header was actually seen. Without this, the "type" variable
    is null causing a Segfault.
    
    Reported-By: Noël Köthe <noel@debian.org>

Comment 4 Fedora Update System 2017-12-08 17:02:54 UTC
wget-1.19.2-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-3e3d1fe1d1

Comment 5 Fedora Update System 2017-12-08 17:03:00 UTC
wget-1.19.2-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c8456c9540

Comment 6 Fedora Update System 2017-12-09 07:29:01 UTC
wget-1.19.2-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-3e3d1fe1d1

Comment 7 Fedora Update System 2017-12-10 00:33:40 UTC
wget-1.19.2-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-c8456c9540

Comment 8 Fedora Update System 2017-12-12 11:26:06 UTC
wget-1.19.2-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2017-12-12 13:43:48 UTC
wget-1.19.2-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.