Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511549 - ovirt-engine and ovirt-engine-dwh postgres processes do not support non default db names
Summary: ovirt-engine and ovirt-engine-dwh postgres processes do not support non defau...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine-metrics
Classification: oVirt
Component: Generic
Version: 1.0.7
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ovirt-4.2.2
: ---
Assignee: Shirly Radco
QA Contact: Lukas Svaty
URL:
Whiteboard:
Depends On: 1458700
Blocks: 1475135
TreeView+ depends on / blocked
 
Reported: 2017-11-09 14:45 UTC by Shirly Radco
Modified: 2018-03-29 10:55 UTC (History)
4 users (show)

Fixed In Version: ovirt-engine-metrics-1.1.2
Doc Type: Bug Fix
Doc Text:
Cause: If the engine and ovirt_engine_history db names are not default, the processes plugin will not be able to report statistics about them. Consequence: The processes plugin will not be able to report statistics about them. Fix: Base the why we collect the db processes stats according to the actual db names. Result: Now non default db names are supported.
Clone Of:
Environment:
Last Closed: 2018-03-29 10:55:13 UTC
oVirt Team: Metrics
rule-engine: ovirt-4.2+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 84804 master MERGED collectd: add role that reads engine variables 2017-12-04 08:34:40 UTC

Description Shirly Radco 2017-11-09 14:45:42 UTC
Description of problem:
ovirt-engine and ovirt-engine-dwh postgres processes do not support non default db names.

If db name are different then "engine" and "ovirt_engine_history"
metrics will be empty for the ovirt-engine and ovirt-engine-dwh in the processes plugin.


Version-Release number of selected component (if applicable):
4.2

How reproducible:
100%

Steps to Reproduce:
1.Change db names
2.Check results in kibana with filter collectd.plugin:processes AND ovirt.entity:engine and split by collectd.plugin_instance
3.

Actual results:
Values are empty for these metrics.

Expected results:
Should add support to non default names.

Additional info:

Comment 2 Yaniv Lavi 2017-11-22 16:07:01 UTC
I don't believe many customers change the default and this has a clear workaround with a manual edit.

Comment 3 Lukas Svaty 2018-01-26 17:21:09 UTC
Reproduction steps:
1. Migrate database to another one -> lsvaty
2. change vars in /etc/ovirt-engine/engine.conf.d/10-setup-database.conf
ENGINE_DB_HOST="localhost"
ENGINE_DB_PORT="5432"
ENGINE_DB_USER="engine"
ENGINE_DB_PASSWORD="password"
ENGINE_DB_DATABASE="lsvaty"
ENGINE_DB_SECURED="False"
ENGINE_DB_SECURED_VALIDATION="False"
ENGINE_DB_DRIVER="org.postgresql.Driver"
ENGINE_DB_URL="jdbc:postgresql://localhost:5432/engine?sslfactory=org.postgresql.ssl.NonValidatingFactory"
3. Check if collectd configuration is updated?
FAIL -> still the same credentials in:
grep -R engine /etc/collectd.d

./20-builtins-conf-for-ovirt-engine.conf:  ProcessMatch pg_engine "postgres: engine engine"

4. samples are still reported though -> Shirly why?
5. Rerun metrics configuration to align the configuration
6. Check collectd configuration 
grep -R engine /etc/collectd.d

./20-builtins-conf-for-ovirt-engine.conf:  ProcessMatch pg_engine "postgres: engine lsvaty"

samples ps_data are not being recorded by metrics store anymore

tested in ovirt-engine-metrics-1.1.2.2-1.el7ev.noarch

Comment 4 Lukas Svaty 2018-01-27 16:09:12 UTC
I found out my migration of the engine actually broke the engine, thus I would like to reverify this one as of functionality.  Moving back to ON_QA

However, the metrics configuration script still should be triggered by migration of database. Shirly is there any way to support this? Maybe documentation update on the migration of DB?

Comment 5 Lukas Svaty 2018-03-21 09:44:10 UTC
verified in ovirt-engine-metrics-1.1.3.3-1.el7ev.noarch on both non-default engine and dwh db names

Comment 6 Sandro Bonazzola 2018-03-29 10:55:13 UTC
This bugzilla is included in oVirt 4.2.2 release, published on March 28th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.2 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.