Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511534 - engine-setup does not update ovirt-ansible-roles
Summary: engine-setup does not update ovirt-ansible-roles
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Setup.Engine
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ---
: ---
Assignee: Sandro Bonazzola
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-09 14:14 UTC by Lucie Leistnerova
Modified: 2017-11-13 08:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-13 08:48:52 UTC
oVirt Team: Integration


Attachments (Terms of Use)

Description Lucie Leistnerova 2017-11-09 14:14:28 UTC
Description of problem:
Running engine-setup doesn't update package ovirt-ansible-roles. It caused host's upgrade to fail with error:
Playbook '/usr/share/ovirt-engine/../ovirt-ansible-roles/playbooks/ovirt-host-upgrade.yml' does not exist, please ensure that ovirt-ansible-roles package is properly installed.

Version-Release number of selected component (if applicable):
ovirt-engine-setup-4.2.0-0.0.master.20171108151837.gita7de53e.el7.centos.noarch

How reproducible: always


Steps to Reproduce:
1. have older engine version
2. update setup packages
yum update ovirt-engine-setup ovirt-engine-setup-plugin-websocket-proxy ovirt-engine-dwh-setup
3. run engine-setup
4. engine is newer version
5. log into admin portal
6. Host -> Installation -> Check for Ugprade

Actual results: ovirt-ansible-roles is not up-to-date, upgrade check fails


Expected results: ovirt-ansible-roles is up-to-date, upgrade check was successful and shows that host can be upgraded


Additional info:
manually update of ovirt-ansible-roles solves the problem and upgrade check works

Comment 1 Yaniv Lavi 2017-11-13 08:48:52 UTC
This is by design. You should run 'yum update' during the upgrade and the roles will be updated.


Note You need to log in before you can comment on or make changes to this bug.