Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511532 - Clicking on save in filters dialog skips first step
Summary: Clicking on save in filters dialog skips first step
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: GA
: 5.10.0
Assignee: Hilda Stastna
QA Contact: Matouš Mojžíš
URL:
Whiteboard: ui:filter
Depends On:
Blocks: 1513114
TreeView+ depends on / blocked
 
Reported: 2017-11-09 14:08 UTC by Matouš Mojžíš
Modified: 2018-06-21 20:20 UTC (History)
4 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1513114 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:20:40 UTC
Category: Bug
Cloudforms Team: CFME Core


Attachments (Terms of Use)
search required after first step save (deleted)
2017-11-09 14:08 UTC, Matouš Mojžíš
no flags Details

Description Matouš Mojžíš 2017-11-09 14:08:54 UTC
Created attachment 1349945 [details]
search required after first step save

Description of problem:


Version-Release number of selected component (if applicable):
5.9.0.7

How reproducible:
Always

Steps to Reproduce:
1. Create a filter
2. Click on Save
3.

Actual results:
It looks like even Save button in second step is triggered.
After first step Save click error "Search Name is required" is displayed even when I didn't press Save in second step yet.

Expected results:


Additional info:

Comment 2 Hilda Stastna 2017-11-10 10:39:49 UTC
fixing https://github.com/ManageIQ/manageiq-ui-classic/pull/2690


Note You need to log in before you can comment on or make changes to this bug.