Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511531 - undocumented sepolicy options
Summary: undocumented sepolicy options
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: policycoreutils
Version: 7.5
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Vit Mojzis
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-09 14:07 UTC by Milos Malik
Modified: 2019-02-27 14:07 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-27 14:07:18 UTC


Attachments (Terms of Use)

Description Milos Malik 2017-11-09 14:07:26 UTC
Description of problem:

Version-Release number of selected component (if applicable):
policycoreutils-newrole-2.5-19.el7.x86_64
policycoreutils-devel-2.5-19.el7.x86_64
policycoreutils-2.5-19.el7.x86_64
policycoreutils-python-2.5-19.el7.x86_64

How reproducible:
* always

Steps to Reproduce:
# sepolicy manpage
usage: sepolicy manpage [-h] [-p PATH] [-o OS] [-w] [-r ROOT] [--source_files]
                        (-a | -d DOMAIN [DOMAIN ...])
sepolicy manpage: error: one of the arguments -a/--all -d/--domain is required
# man sepolicy-manpage | col -b | grep -- -
sepolicy-manpage(8)					   sepolicy-manpage(8)
       sepolicy-manpage	 -  Generate a man page based on the installed SELinux
       sepolicy manpage [-w] [-h] [-p PATH ] [-r ROOTDIR ] [-a | -d ]
       -a, --all
       -d, --domain
       -h, --help
       -p, --path
       -r, --root
       -w, --web
#

Actual results:
 * the --source_files option is not documented
 * the -o/--os option is not documented

Expected results:
 * all options are documented

Additional information:
 * the issue is present in RHEL-7.4 too

Comment 1 Zdenek Pytela 2019-02-27 14:07:18 UTC
This issue was not selected to be included in Red Hat Enterprise Linux 7.7 because it is seen either as low or moderate impact to a small number of use-cases. The next release will be in Maintenance Support 1 Phase, which means that qualified Critical and Important Security errata advisories (RHSAs) and Urgent Priority Bug Fix errata advisories (RHBAs) may be released as they become available.

We will now close this issue, but if you believe that it qualifies for the Maintenance Support 1 Phase, please re-open; otherwise, we recommend moving the request to Red Hat Enterprise Linux 8 if applicable.


Note You need to log in before you can comment on or make changes to this bug.