Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511516 - [pulseaudio] assertion 'PA_SINK_INPUT_IS_LINKED(i->state)' failed - pulseaudio killed by SIGABRT
Summary: [pulseaudio] assertion 'PA_SINK_INPUT_IS_LINKED(i->state)' failed - pulseaudi...
Keywords:
Status: CLOSED DUPLICATE of bug 1472285
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 26
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-09 13:52 UTC by Lukasz Dorau
Modified: 2017-12-14 15:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-11 16:22:28 UTC


Attachments (Terms of Use)
outout of "abrt-cli i -v -d" (deleted)
2017-11-09 14:24 UTC, Lukasz Dorau
no flags Details
gdb backtrace (deleted)
2017-11-09 14:40 UTC, Lukasz Dorau
no flags Details
journalctl log with debug log level (deleted)
2017-11-15 09:38 UTC, Lukasz Dorau
no flags Details

Description Lukasz Dorau 2017-11-09 13:52:44 UTC
Description of problem:
pulseaudio quits unexpectedly at sink-input.c several times per day

Version-Release number of selected component (if applicable):
pulseaudio-11.1-2.fc26.x86_64

How reproducible:
pulseaudio quits unexpectedly several times per day

Steps to Reproduce:
1) wait about one hour for pulseaudio to quit unexpectedly

Actual results (from syslog):

Nov 09 08:28:44 gklab-124-124 pulseaudio[8775]: [pulseaudio] sink-input.c: Assertion 'PA_SINK_INPUT_IS_LINKED(i->state)' failed at pulsecore/sink-input.c:1883, function pa_sink_input_finish_move(). Aborting.
Nov 09 08:28:45 gklab-124-124 pulseaudio[8846]: [pulseaudio] main.c: User-configured server at {254c893e99d74f488122ef0c95d481d9}unix:/run/user/1000/pulse/native, which appears to be local. Probing deeper.
Nov 09 08:28:45 gklab-124-124 pulseaudio[8849]: [pulseaudio] pid.c: Stale PID file, overwriting.
Nov 09 08:28:46 gklab-124-124 pulseaudio[8849]: [pulseaudio] backend-ofono.c: Failed to register as a handsfree audio agent with ofono: org.freedesktop.DBus.Error.ServiceUnknown: The name org.ofono was not provided by any .service files
Nov 09 08:28:49 gklab-124-124 systemd-coredump[8845]: Process 8775 (pulseaudio) of user 1000 dumped core.
    
Stack trace of thread 8775:
#0  0x00007f3d4a45b9fb raise (libc.so.6)
#1  0x00007f3d4a45d800 abort (libc.so.6)
#2  0x00007f3d4d9d35dc pa_sink_input_finish_move (libpulsecore-11.1.so)
#3  0x00007f3d4d9d686d pa_sink_move_all_finish (libpulsecore-11.1.so)
#4  0x00007f3d371afdba card_set_profile (module-alsa-card.so)
#5  0x00007f3d4d9b2796 pa_card_set_profile (libpulsecore-11.1.so)
#6  0x00007f3d375bd73d switch_to_port (module-switch-on-port-available.so)
#7  0x00007f3d375bdac8 port_available_hook_callback (module-switch-on-port-available.so)
#8  0x00007f3d4d9b6dc3 pa_hook_fire (libpulsecore-11.1.so)
#9  0x00007f3d371b08c7 report_jack_state (module-alsa-card.so)
#10 0x00007f3d36f75ec8 mixer_class_event (libalsa-util.so)
#11 0x00007f3d36cacee4 hctl_elem_event_handler (libasound.so.2)
#12 0x00007f3d36ca377b snd_hctl_handle_events (libasound.so.2)
#13 0x00007f3d36cae051 snd_mixer_handle_events (libasound.so.2)
#14 0x00007f3d36f7b499 io_cb (libalsa-util.so)
#15 0x00007f3d4d75f888 pa_mainloop_dispatch (libpulse.so.0)
#16 0x00007f3d4d75fc5e pa_mainloop_iterate (libpulse.so.0)
#17 0x00007f3d4d75fce0 pa_mainloop_run (libpulse.so.0)
#18 0x00005637b03ee33e main (pulseaudio)
#19 0x00007f3d4a44588a __libc_start_main (libc.so.6)
#20 0x00005637b03ee9da _start (pulseaudio)

Stack trace of thread 8840:
#0  0x00007f3d4a529e06 ppoll (libc.so.6)
#1  0x00007f3d4d9c233f pa_rtpoll_run (libpulsecore-11.1.so)
#2  0x00007f3cffdfcc18 thread_func (module-null-sink.so)
#3  0x00007f3d4cc033a8 internal_thread_func (libpulsecommon-11.1.so)
#4  0x00007f3d4af2336d start_thread (libpthread.so.0)
#5  0x00007f3d4a535e1f __clone (libc.so.6)

Stack trace of thread 8785:
#0  0x00007f3d4a529e06 ppoll (libc.so.6)
#1  0x00007f3d4d9c233f pa_rtpoll_run (libpulsecore-11.1.so)
#2  0x00007f3d36f91dfe thread_func (libalsa-util.so)
#3  0x00007f3d4cc033a8 internal_thread_func (libpulsecommon-11.1.so)
#4  0x00007f3d4af2336d start_thread (libpthread.so.0)
#5  0x00007f3d4a535e1f __clone (libc.so.6)

Stack trace of thread 8841:
#0  0x00007f3d4a529e06 ppoll (libc.so.6)
#1  0x00007f3d4d9c233f pa_rtpoll_run (libpulsecore-11.1.so)
#2  0x00007f3d36f8ba05 thread_func (libalsa-util.so)
#3  0x00007f3d4cc033a8 internal_thread_func (libpulsecommon-11.1.so)
#4  0x00007f3d4af2336d start_thread (libpthread.so.0)
#5  0x00007f3d4a535e1f __clone (libc.so.6)
~                                                                                                                                                                                                                  

Expected results:
pulseaudio does not quit unexpectedly

Additional info:
$ ps aux | grep pulseaudio
gdm       1284  0.0  0.0 1248200 11024 ?       S<l  13:03   0:00 /usr/bin/pulseaudio --start --log-target=syslog
ldorau   10241  0.6  0.0 1285868 12124 ?       S<l  14:49   0:00 /usr/bin/pulseaudio --start --log-target=syslog

Comment 1 Lukasz Dorau 2017-11-09 13:54:55 UTC
Report:

--- Running report_EmergencyAnalysis ---
Compressing data
Sending /var/tmp/ccpp-2017-11-09-14:49:23.666738-1812.tar.gz to https://retrace.fedoraproject.org
Successfully created https://retrace.fedoraproject.org/faf/dumpdirs/new/ccpp-2017-11-09-14:49:23.666738-1812.tar.gz

Comment 2 Lukasz Dorau 2017-11-09 14:24:44 UTC
Created attachment 1349959 [details]
outout of "abrt-cli i -v -d"

outout of "abrt-cli i -v -d":
$ abrt-cli i -v -d /var/spool/abrt/ccpp-2017-11-09-14:49:23.666738-1812 > abrt-cli.txt

Comment 3 Lukasz Dorau 2017-11-09 14:25:58 UTC
reason:         raise(): pulseaudio killed by SIGABRT

Comment 4 Lukasz Dorau 2017-11-09 14:40:20 UTC
Created attachment 1349964 [details]
gdb backtrace

Comment 5 Lukasz Dorau 2017-11-09 14:42:28 UTC
The beginning of the backtrace:

#0  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:51
#1  0x00007f9856f25800 in __GI_abort () at abort.c:89
#2  0x00007f985a49b5dc in pa_sink_input_assert_ref (o=<optimized out>) at pulsecore/sink-input.h:257
#3  pa_sink_input_finish_move (i=i@entry=0x5568422a2f50, dest=dest@entry=0x5568422df790, save=save@entry=false) at pulsecore/sink-input.c:1881
#4  0x00007f985a49e86d in pa_sink_move_all_finish (s=0x5568422df790, q=q@entry=0x5568423e7ee0, save=save@entry=false) at pulsecore/sink.c:923
#5  0x00007f9843bf3dba in card_set_profile (c=0x5568422fb910, new_profile=0x55684224cf20) at modules/alsa/module-alsa-card.c:255

The whole backtrace is attached.

Comment 6 Lukasz Dorau 2017-11-14 08:03:57 UTC
I do not use any audio devices. I have no audio devices connected to the audio outputs. I do not use audio at this machine at all, but pulseaudio aborts regularly.

Comment 7 Lukasz Dorau 2017-11-14 08:07:43 UTC
It seems to be a duplicate of:
https://bugzilla.redhat.com/show_bug.cgi?id=1472285

*** This bug has been marked as a duplicate of bug 1472285 ***

Comment 8 Lukasz Dorau 2017-11-15 09:38:33 UTC
Created attachment 1352465 [details]
journalctl log with debug log level

Comment 9 Lukasz Dorau 2017-11-15 10:24:47 UTC
It happened __103__ times on my machine during the last month.

Comment 10 Rex Dieter 2017-12-11 16:22:28 UTC
re-duping

*** This bug has been marked as a duplicate of bug 1472285 ***


Note You need to log in before you can comment on or make changes to this bug.