Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511514 - External monitor shuts off when laptop lid closes under wayland
Summary: External monitor shuts off when laptop lid closes under wayland
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mutter
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Florian Müllner
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-09 13:48 UTC by Tomas Pelka
Modified: 2018-05-17 14:39 UTC (History)
5 users (show)

Fixed In Version: mutter-3.26.2-7.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 13:07:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 13:08:27 UTC
GNOME Bugzilla 788915 None None None 2017-11-09 13:49:25 UTC

Description Tomas Pelka 2017-11-09 13:48:33 UTC
Description of problem:
control-center display user experience is very bad if you have laptop with two or more attached external displays. Displays layout can't be adjusted when lid is closed.

Version-Release number of selected component (if applicable):
control-center-3.26.2-1.el7
mutter-3.26.2-3.el7

How reproducible:
100%

Steps to Reproduce:
1. have at least two displays attached 
2. close the lid
3. try to change displays position on control-center

Actual results:
Very hard to do it

Expected results:
Should be smooth as with old control-center

Additional info:

Comment 1 Tomas Pelka 2017-11-22 14:38:34 UTC
Sorry for mixing this bz with g-c-c, this is not related to what I described in description of this bz. Please take it as downstream clone of  http://bugzilla.gnome.org/show_bug.cgi?id=788915

Comment 2 Florian Müllner 2018-02-01 22:18:08 UTC
The issue has been fixed upstream, so it's easy enough to include; marking as dev-ack.

Comment 7 errata-xmlrpc 2018-04-10 13:07:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770


Note You need to log in before you can comment on or make changes to this bug.