Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511493 - OVN configures ovn-bridge-mappings on all the nodes even if they don't provide external connectivity
Summary: OVN configures ovn-bridge-mappings on all the nodes even if they don't provid...
Keywords:
Status: CLOSED DUPLICATE of bug 1510879
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: James Slagle
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-09 13:11 UTC by Eran Kuris
Modified: 2017-11-13 14:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-13 14:55:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1730711 None None None 2017-11-09 13:11:18 UTC

Description Eran Kuris 2017-11-09 13:11:19 UTC
Description of problem:
For OVN deployments, in order for any node (be it compute or controller) to provide external connectivity to the tenant traffic, ovn-controller service should be running and the ovn-bridge-mappings (eg. OVNBridgeMappings=datacentre:br-ex) should be defined. Tripleo when deployed with OVN does it, but it does on all the nodes where (ovn-controller service is enabled) even if those nodes do not have external connectivity. Neutron ML2 OVN driver considers all the nodes configured with "ovn-bridge-mappings" as candidates and could schedule on any node. This will cause problems on deployments where only controller (or network) nodes provide external connectivity.

Version-Release number of selected component (if applicable):
(overcloud) [stack@undercloud-0 ~]$ cat /etc/yum.repos.d/latest-installed 
12   -p 2017-11-03.4
(overcloud) [stack@undercloud-0 ~]$ rpm -qa |grep director
rhosp-director-images-ipa-12.0-20171103.1.el7ost.noarch
rhosp-director-images-12.0-20171103.1.el7ost.noarch
(overcloud) [stack@undercloud-0 ~]$ rpm -qa |grep triple
python-tripleoclient-7.3.2-2.el7ost.noarch
openstack-tripleo-image-elements-7.0.1-0.20171020101256.2e61e31.el7ost.noarch
openstack-tripleo-heat-templates-7.0.3-0.20171024200823.el7ost.noarch
openstack-tripleo-common-containers-7.6.3-0.20171028055750.el7ost.noarch
openstack-tripleo-puppet-elements-7.0.1-0.20171020122223.82d7e6c.el7ost.noarch
openstack-tripleo-common-7.6.3-0.20171028055750.el7ost.noarch
openstack-tripleo-ui-7.4.2-2.el7ost.noarch
openstack-tripleo-validations-7.4.1-2.el7ost.noarch
puppet-tripleo-7.4.3-0.20171025110206.el7ost.noarch


How reproducible:
always

Steps to Reproduce:
1.deploy ovn HA setup
2.create router and set gateway 

3. check connectivity to the router 

Actual results:
no connectivity
Expected results:


Additional info:

Comment 1 Jakub Libosvar 2017-11-13 14:55:00 UTC

*** This bug has been marked as a duplicate of bug 1510879 ***


Note You need to log in before you can comment on or make changes to this bug.