Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511420 - [RFE] API for running VM with an ISO from the DATA domain
Summary: [RFE] API for running VM with an ISO from the DATA domain
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ovirt-4.2.1
: ---
Assignee: Tal Nisan
QA Contact: Avihai
URL:
Whiteboard:
Depends On: 1122970 1533356 1536826
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-09 10:17 UTC by Raz Tamir
Modified: 2018-02-22 10:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-22 10:00:21 UTC
oVirt Team: Storage
rule-engine: ovirt-4.2+
ratamir: testing_plan_complete+
ylavi: planning_ack+
rule-engine: devel_ack+
ratamir: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 85768 master MERGED Add content type to the disk entity 2018-01-03 12:46:04 UTC
oVirt gerrit 85912 master MERGED restapi: Map content type for disks 2018-01-03 16:27:51 UTC
oVirt gerrit 85934 model_4.2 MERGED Add content type to the disk entity 2018-01-03 13:02:38 UTC
oVirt gerrit 85945 master MERGED restapi: Update to model 4.2.28 2018-01-03 14:20:46 UTC
oVirt gerrit 86518 master MERGED Updating the model version to 4.2.28 2018-01-18 07:57:15 UTC

Description Raz Tamir 2017-11-09 10:17:50 UTC
Description of problem:
The feature described here https://bugzilla.redhat.com/show_bug.cgi?id=1122970
requires a python SDK api.
We need it to be able to automate it


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Allon Mureinik 2017-11-09 12:02:06 UTC
Uploading is just a regular disk upload, nothing special here.

Running a VM with this ISO of course needs an API, which, indeed, is not present yet.

Comment 2 Yaniv Kaul 2017-12-27 14:46:15 UTC
(In reply to Allon Mureinik from comment #1)
> Uploading is just a regular disk upload, nothing special here.

So why is this BZ in NEW state?

Comment 3 Tal Nisan 2017-12-27 16:11:49 UTC
We have just a small gap in adding the content type field and type to the API in order for it to be used when creating the disk via REST, a patch was posted earlier

Comment 5 Avihai 2018-01-25 15:19:08 UTC
This is the current status of this flow (running VM with ISO disk) :

* Uploading ISO file via UI - works
* Uploading ISO file via SDK which includes :
    - Creating ISO disk via SDK - DOES NOT WORK - see Bug 1533356 
    - Uploading ISO file - works as this is a regular upload as a data type disk.

* Attaching the ISO to the VM as CD via UI-works (should work for REST as this is an old function)
* Running the attached VM - does not work - Bug 1536826 

As I see it until bugs 1533356&1536826 is not fixed I can not verify this bug.
Please correct me if I'm wrong.

Comment 6 Tal Nisan 2018-01-29 09:39:50 UTC
Avihai, bug 1533356 should be ON_QA, not sure why it wasn't moved automatically as there is a tracker attached.
Please check, as for the bug 1536826, we looked into it and it will be fixed soon.

Comment 7 Avihai 2018-02-11 10:03:46 UTC
(In reply to Tal Nisan from comment #6)
> Avihai, bug 1533356 should be ON_QA, not sure why it wasn't moved
> automatically as there is a tracker attached.
> Please check, as for the bug 1536826, we looked into it and it will be fixed
> soon.

Tal , the same issue still occurs on latest downstream with the following Engine/VDSM/libvirt:

ovirt-engine-4.2.1.6-0.1.el7.noarch
vdsm-client-4.20.17-1.el7ev.noarch
libvirt-3.9.0-7.el7.x86_64
qemu-kvm-rhev-2.10.0-20.el7.x86_64

So this issue can not be verified yet .

Comment 8 Avihai 2018-02-19 12:39:14 UTC
Verified on engine 4.2.2

* Uploading ISO file via UI - works
* Uploading ISO file via SDK 
    - Creating ISO disk via SDK -works
    - Uploading ISO file - works
* Running the attached VM - works

Comment 9 Sandro Bonazzola 2018-02-22 10:00:21 UTC
This bugzilla is included in oVirt 4.2.1 release, published on Feb 12th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.1 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.