Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511373 - ipc test fails on s390x architecture
Summary: ipc test fails on s390x architecture
Keywords:
Status: CLOSED DUPLICATE of bug 1511465
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: 3.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-09 09:17 UTC by Vaibhav Vaingankar
Modified: 2017-11-09 12:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-09 12:19:51 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Vaibhav Vaingankar 2017-11-09 09:17:11 UTC
Description of problem:
Test ./tests/features/ipc.t is fails on executing ./tests/features/ipctest.py
Script received signal SIGSEGV, Segmentation Error (Core Dumb) in __GLFS_ENTRY_VALIDATE_FS (fs, invalid_fs); at glfs.c:


Version-Release number of selected component (if applicable):
3.10.7

How reproducible:
Build and install glusterfs on System Z (s390x) 
run ./tests/features/ipc.t testcase


Steps to Reproduce:
1. git clone https://github.com/gluster/glusterfs && cd glusterfs
2. git checkout v3.10.7
3. ./autogen.sh
4. ./configure
5. make
6. make install
7. ./run-tests.sh ./tests/features/ipc.t



Actual results:

ok
All tests successful.
Files=1, Tests=78, 45 wallclock secs ( 0.14 usr  0.03 sys +  9.27 cusr  4.64 csys = 14.08 CPU)
Result: PASS



Expected results:

Failed 1/6 subtests

Test Summary Report
-------------------
./tests/features/ipc.t (Wstat: 0 Tests: 6 Failed: 1)
  Failed test:  6
Files=1, Tests=6,  3 wallclock secs ( 0.03 usr  0.00 sys +  0.50 cusr  0.34 csys =  0.87 CPU)
Result: FAIL
./tests/features/ipc.t: bad status 1

       *********************************
       *       REGRESSION FAILED       *
       * Retrying failed tests in case *
       * we got some spurous failures  *
       *********************************



Additional info:
Thread 1 "python" received signal SIGSEGV, Segmentation fault.
0x000003fffd89c8e4 in pub_glfs_set_volfile_server (fs=0x33f110, transport=0x3fffdc2466c "tcp", host=0x3fffdc126e4 "73da538ef028", port=<optimized out>) at glfs.c:425
425             __GLFS_ENTRY_VALIDATE_FS (fs, invalid_fs);

Comment 1 Vaibhav Vaingankar 2017-11-09 12:20:25 UTC

*** This bug has been marked as a duplicate of bug 1511465 ***


Note You need to log in before you can comment on or make changes to this bug.