Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511357 - Task "Reload generated facts" failed while scaling up masters
Summary: Task "Reload generated facts" failed while scaling up masters
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.7.z
Assignee: Russell Teague
QA Contact: Gan Huang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-09 08:43 UTC by Gan Huang
Modified: 2018-04-05 09:31 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Registered install_result wasn't available when the install task was skipped for containerized hosts so default it.
Clone Of:
Environment:
Last Closed: 2018-04-05 09:30:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0636 None None None 2018-04-05 09:31:32 UTC

Description Gan Huang 2017-11-09 08:43:31 UTC
Description of problem:
TASK [openshift_ca : Reload generated facts] ***********************************
task path: /home/slave5/workspace/Run-Ansible-Playbooks/private-openshift-ansible/roles/openshift_ca/tasks/main.yml:19
fatal: [qe-ghuang-auto-14065-rskr-rhel-1.1109-vos.qe.rhcloud.com]: FAILED! => {"failed": true, "msg": "The conditional check 'hostvars[openshift_ca_host].install_result | changed' failed. The error was: |changed expects a dictionary\n\nThe error appears to have been in '/home/slave5/workspace/Run-Ansible-Playbooks/private-openshift-ansible/roles/openshift_ca/tasks/main.yml': line 19, column 3, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n\n- name: Reload generated facts\n  ^ here\n"}

Version-Release number of the following components:
openshift-ansible-3.7.4-1.git.0.254e849.el7.noarch.rpm
ansible-2.4.0.0-5.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. Trigger HA containerized installation on RHEL
2. Scaling up a containerized master with RHEL
3.

Actual results:
see above

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 3 Gan Huang 2017-11-09 08:51:19 UTC
Seems it's related to https://github.com/openshift/openshift-ansible/pull/5978

It's weird for me that the fresh installation went smoothly, but happening for scaling up.

Comment 6 Gan Huang 2017-11-15 04:45:22 UTC
The issue is also present in rpm installation/scaling-up,and updating the bug title.

TASK [openshift_ca : Install the base package for admin tooling] ***************
ok: [ec2-54-87-255-240.compute-1.amazonaws.com -> ec2-52-91-219-63.compute-1.amazonaws.com] => {"changed": false, "failed": false, "msg": "", "rc": 0, "results": ["atomic-openshift-3.7.7-1.git.0.e05180c.el7.x86_64 providing atomic-openshift-3.7.7 is already installed"]}

TASK [openshift_ca : Reload generated facts] ***********************************
fatal: [ec2-54-87-255-240.compute-1.amazonaws.com]: FAILED! => {"failed": true, "msg": "The conditional check 'hostvars[openshift_ca_host].install_result | changed' failed. The error was: |changed expects a dictionary\n\nThe error appears to have been in '/home/slave1/workspace/Run-Ansible-Playbooks/private-openshift-ansible/roles/openshift_ca/tasks/main.yml': line 19, column 3, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n\n- name: Reload generated facts\n  ^ here\n"}
	to retry, use: --limit @/home/slave1/workspace/Run-Ansible-Playbooks/private-openshift-ansible/playbooks/byo/openshift-master/scaleup.retry

Comment 7 openshift-github-bot 2018-01-18 02:38:44 UTC
Commit pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/e5a319cf8c7cc6d36ddb9fdc9e69e9dd1b8eb3f5
Merge pull request #6076 from abutcher/bz1511357

Bug 1511357: Task "Reload generated facts" failed while scaling up containerized masters

Comment 9 Gan Huang 2018-01-30 07:54:20 UTC
The fix is not in openshift-ansible-3.7.27-1.git.0.ae95fc3.el7.noarch.rpm

Comment 10 Russell Teague 2018-01-30 13:22:11 UTC
Opened 3.7 PR: https://github.com/openshift/openshift-ansible/pull/6937

Comment 11 Russell Teague 2018-02-02 16:02:47 UTC
Waiting for 3.7 build

Comment 12 Russell Teague 2018-02-06 13:55:31 UTC
openshift-ansible-3.7.28-1

Comment 13 Gan Huang 2018-02-07 05:39:43 UTC
Verified in openshift-ansible-3.7.28-1.git.0.12b5132.el7.noarch.rpm

Comment 18 errata-xmlrpc 2018-04-05 09:30:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0636


Note You need to log in before you can comment on or make changes to this bug.