Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511340 - [Regression] Missing buttons in different parts of the UI
Summary: [Regression] Missing buttons in different parts of the UI
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: All
OS: All
urgent
urgent
Target Milestone: Beta 1
: 5.9.0
Assignee: Eric Winchell
QA Contact: Tasos Papaioannou
URL:
Whiteboard:
: 1511946 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-09 07:54 UTC by Dmitry Misharov
Modified: 2018-03-06 15:24 UTC (History)
8 users (show)

Fixed In Version: 5.9.0.8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-06 15:24:06 UTC
Category: Bug
Cloudforms Team: CFME Core


Attachments (Terms of Use)

Description Dmitry Misharov 2017-11-09 07:54:19 UTC
Description of problem:
There is no way to save the configuration via UI. "Save" button is missing. Also it's not possible to add Policy profile.

Version-Release number of selected component (if applicable):
5.9.0.7.20171107212356_ed87902

How reproducible:
Always

Steps to Reproduce:
1. Navigate to Configuration.

Actual results:
Missing "Save", "Cancel" buttons

Expected results:
"Save" and other buttons must be presented.

Comment 2 Dmitry Misharov 2017-11-13 15:45:24 UTC
*** Bug 1511946 has been marked as a duplicate of this bug. ***

Comment 3 CFME Bot 2017-11-29 20:34:33 UTC
New commit detected on ManageIQ/manageiq-ui-classic/gaprindashvili:
https://github.com/ManageIQ/manageiq-ui-classic/commit/c03b8fb599102cba14baae5037ab1c8e46c66312

commit c03b8fb599102cba14baae5037ab1c8e46c66312
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Thu Nov 9 09:50:13 2017 -0800
Commit:     Satoe Imaishi <simaishi@redhat.com>
CommitDate: Thu Nov 9 13:11:29 2017 -0500

    Merge pull request #2685 from ManageIQ/revert-2618-form_button_cleanup1
    
    Revert "form button styling clean up"
    (cherry picked from commit 36b7cf1731b4437dd225aaed0e2fc1118e57cbfe)
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1511340
    https://bugzilla.redhat.com/show_bug.cgi?id=1510911
    https://bugzilla.redhat.com/show_bug.cgi?id=1511192
    https://bugzilla.redhat.com/show_bug.cgi?id=1511188
    https://bugzilla.redhat.com/show_bug.cgi?id=1510650
    https://bugzilla.redhat.com/show_bug.cgi?id=1511325
    https://bugzilla.redhat.com/show_bug.cgi?id=1511542

 app/assets/stylesheets/patternfly_overrides.scss   |  15 +-
 app/views/layouts/_x_dialog_buttons.html.haml      | 105 ++++----
 app/views/layouts/_x_edit_buttons.html.haml        | 264 ++++++++++-----------
 app/views/layouts/_x_form_buttons.html.haml        |   2 +-
 .../layouts/angular/_paging_div_buttons.html.haml  |   3 +-
 app/views/vm_common/_right_size.html.haml          |   2 +-
 6 files changed, 191 insertions(+), 200 deletions(-)

Comment 4 Tasos Papaioannou 2017-12-01 18:15:32 UTC
Verified on 5.9.0.11.


Note You need to log in before you can comment on or make changes to this bug.