Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511291 - Adding negative value to resource quota yaml file while Setting Limits for Users and Projects.
Summary: Adding negative value to resource quota yaml file while Setting Limits for Us...
Keywords:
Status: CLOSED DUPLICATE of bug 1511289
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Command Line Interface
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Fabiano Franz
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-09 05:33 UTC by kavitha
Modified: 2017-11-09 05:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-09 05:48:35 UTC


Attachments (Terms of Use)

Description kavitha 2017-11-09 05:33:22 UTC
Description of problem:
Adding negative value to resource quota yaml file while Setting Limits for Users and Projects: while creating quota where persistent volume claim given with negative values 
I could execute the command successfully without any error.

Version-Release number of selected component (if applicable):
atomic-openshift-utils-3.6.173.0.48-1.git.0.1609d30.el7.noarch

How reproducible:
resource-quota.yaml

apiVersion: v1
kind: ResourceQuota
metadata:
  name: core-object-counts
spec:
  hard:
    configmaps: "10"
    persistentvolumeclaims: "-4"
    replicationcontrollers: "20"
    secrets: "10"
    services: "10"


Steps to Reproduce:
1.login to Openshift CLI 
2.oc create -f resource-quota.yaml


Actual results:
It is successfully executing and creating quota.

Expected results:
It should throw the error after detecting the negative value

Additional info:

Comment 1 kavitha 2017-11-09 05:48:35 UTC

*** This bug has been marked as a duplicate of bug 1511289 ***


Note You need to log in before you can comment on or make changes to this bug.