Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511263 - SSL for docs.gluster.org
Summary: SSL for docs.gluster.org
Keywords:
Status: CLOSED DUPLICATE of bug 1489280
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-09 02:44 UTC by Nigel Babu
Modified: 2018-03-12 15:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-12 15:30:45 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Nigel Babu 2017-11-09 02:44:32 UTC
1. Point docs.gluster.org to a server we own. And redirect HTTP to RTD.
2. Once the DNS changes are in place, setup SSL with letsencrypt.

Comment 1 Michael S. 2018-03-08 14:18:35 UTC
So we have docs.proxy.gluster.org setup now, but it do not seems to work as we want. Is there anything to do RTD side for that ?

Comment 2 Michael S. 2018-03-08 16:42:28 UTC
Ok so we need to add the domain:
https://docs.readthedocs.io/en/latest/alternate_domains.html

For ssl, we have ssl from browser to proxy, but that's cleartext to RTD. is that ok, I assumed we want it for SEO mostly.

Comment 3 Michael S. 2018-03-12 15:30:45 UTC
ok, so we switched.

*** This bug has been marked as a duplicate of bug 1489280 ***


Note You need to log in before you can comment on or make changes to this bug.