Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511201 - UDS threads do not identify the VDO device they relate to
Summary: UDS threads do not identify the VDO device they relate to
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kmod-kvdo
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Thomas Jaskiewicz
QA Contact: Jakub Krysl
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-08 21:57 UTC by Bryan Gurney
Modified: 2018-04-10 16:26 UTC (History)
3 users (show)

Fixed In Version: 6.1.0.42
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 16:25:27 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:0900 None None None 2018-04-10 16:26:06 UTC

Description Bryan Gurney 2017-11-08 21:57:15 UTC
Description of problem:
UDS is still creating threads using the thread names from user-mode albireo. So we have: callbackWorker, zoneIndexWorker (2 of these), volumeReader (2 of these), chapterWriter.

Version-Release number of selected component (if applicable):
kmod-kvdo-6.1.0.34-7.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Create a VDO volume.
2. Run "ps aux".
3. Look for threads named "callbackWorker", "chapterWriter", "volumeReader", or "zoneIndexWorker".

Actual results:
There are threads named threads named "callbackWorker", "chapterWriter", "volumeReader", or "zoneIndexWorker", with no indication of the associated VDO volume.

Expected results:
The UDS threads that are associated with a VDO volume have a label indicating their association.


Additional info:

Comment 2 Thomas Jaskiewicz 2017-11-09 22:37:11 UTC
Fixed in VDO 6.1.0.42

Threads that are common to all UDS indices have names starting with uds:.  "callbackWorker" becomes "uds:callbsckW".  The code has other such threads, but VDO will not use them.

Threads belonging to a VDO instance have names starting with kvdo0:.  The "0" is replaced by the same number so that the threads have the same kvdo<number>: prefix as the VDO threads for that VDO instance.  "chapterWriter" becomes "kvdo0:writer", "triageWorker" becomes "kvdo0:triageW", "volumeReader" becomes "kvdo0:reader", and "zoneIndexWorker" becomes "kvdo0:indexW".

Comment 4 Jakub Krysl 2017-11-14 13:54:36 UTC
Tested with kmod-kvdo-6.1.0.46-8, created 2 VDO volumes and compared ps aux. The only thread common to them is 'uds:callbsckW'. Other threads start with 'kvdo' and correct number of said vdo. When VDOs are removed, the only thread remaining is 'uds:callbsckW'.

Comment 7 errata-xmlrpc 2018-04-10 16:25:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0900


Note You need to log in before you can comment on or make changes to this bug.