Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511194 - Lifecycle provision fails against out-of-box method
Summary: Lifecycle provision fails against out-of-box method
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning
Version: 5.8.0
Hardware: All
OS: All
unspecified
high
Target Milestone: GA
: cfme-future
Assignee: Greg McCullough
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-08 21:00 UTC by Ryan Spagnola
Modified: 2017-12-05 13:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-08 22:03:38 UTC
Category: Bug
Cloudforms Team: CFME Core


Attachments (Terms of Use)

Description Ryan Spagnola 2017-11-08 21:00:18 UTC
Description of problem:
When trying lifecycle provision it fails in vmware_CustomizeRequest.

Version-Release number of selected component (if applicable):
5.8.2.3

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
[----] E, [2017-11-08T10:04:33.455128 #5814:4fd01c] ERROR -- : Q-task_id([miq_provision_101000000001039]) <AEMethod vmware_customizerequest> vmware_CustomizeRequest - [Unable to customize Disks.]
/opt/rh/rh-ruby23/root/usr/local/share/gems/gems/miq_dev_util-1.0.0/lib/miq_dev_util/automate.rb:14:in `instantiate_or_raise'
/CBTS/Infrastructure/VM/Provisioning/StateMachines/Methods/vmware_CustomizeRequest:32:in `<main>'
[----] I, [2017-11-08T10:04:33.471843 #5814:47313c]  INFO -- : Q-task_id([miq_provision_101000000001039]) <AEMethod [/CBTS/Infrastructure/VM/Provisioning/StateMachines/Methods/vmware_CustomizeRequest]> Ending
[----] I, [2017-11-08T10:04:33.472119 #5814:47313c]  INFO -- : Q-task_id([miq_provision_101000000001039]) Aborting instantiation because [Method exited with rc=MIQ_ABORT]
[----] E, [2017-11-08T10:04:33.472412 #5814:47313c] ERROR -- : Q-task_id([miq_provision_101000000001039]) State=<CustomizeRequest> running  raised exception: <Method exited with rc=MIQ_ABORT>

Comment 2 Greg McCullough 2017-11-08 21:35:35 UTC
To be clear, vmware_customizerequest is largely empty method we ship out of the box.  This error is being raised from a method the custom has copied into their own domain and modified.

The method we ship is the following which could never produce a "Unable to customize Disks" error:
#
# Description: This method is used to Customize the VMware and VMware PXE Provisioning Request
#

# Get provisioning object
prov = $evm.root["miq_provision"]

$evm.log("info", "Provisioning ID:<#{prov.id}> Provision Request ID:<#{prov.miq_provision_request.id}> Provision Type: <#{prov.provision_type}>")


Note You need to log in before you can comment on or make changes to this bug.