Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511168 - dbus error "Activated service 'com.redhat.SubscriptionManager' failed
Summary: dbus error "Activated service 'com.redhat.SubscriptionManager' failed
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.5
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: Red Hat subscription-manager QE Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-08 19:51 UTC by Jan Stavel
Modified: 2017-11-23 22:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-23 20:19:46 UTC


Attachments (Terms of Use)

Description Jan Stavel 2017-11-08 19:51:32 UTC
Description of problem:

I cannot open a subscription plugin in cockpit.
A page of the plugin says:

Couldn't get system subscription status. Please ensure subscription-manager is installed.

Unable to connect

Version-Release number of selected component (if applicable):

[root@jstavel-rhel7-server-01 ~]# rpm -qa | egrep "cockpit|subscription|rhsm"
   cockpit-bridge-154-1.el7.x86_64
   cockpit-ws-154-1.el7.x86_64
   subscription-manager-rhsm-certificates-1.20.5-1.el7.x86_64
   cockpit-154-1.el7.x86_64
   subscription-manager-1.20.5-1.el7.x86_64
   subscription-manager-plugin-container-1.20.5-1.el7.x86_64
   cockpit-system-154-1.el7.noarch
   subscription-manager-rhsm-1.20.5-1.el7.x86_64

[root@jstavel-rhel7-server-01 ~]# cat /etc/os-release 
   VERSION="7.5 (Maipo)"
   ID="rhel"
   ID_LIKE="fedora"
   VERSION_ID="7.5"
   ANSI_COLOR="0;31"
   HOME_URL="https://www.redhat.com/"
   BUG_REPORT_URL="https://bugzilla.redhat.com/"
   REDHAT_BUGZILLA_PRODUCT="Red Hat Enterprise Linux 7"
   REDHAT_BUGZILLA_PRODUCT_VERSION="7.5"
   REDHAT_SUPPORT_PRODUCT="Red Hat Enterprise Linux"
   REDHAT_SUPPORT_PRODUCT_VERSION="7.5 Beta"
   PRIVACY_POLICY_URL="http://www.redhat.com/en/about/privacy-policy"
   NAME="Red Hat Enterprise Linux Server"
   PRETTY_NAME="Red Hat Enterprise Linux Server 7.5 Beta (Maipo)"
   VARIANT="Server"
   VARIANT_ID="server"
   CPE_NAME="cpe:/o:redhat:enterprise_linux:7.5:beta:server"


How reproducible:

each time.

Steps to Reproduce:
1. install cockpit && subscription-manager
2. firewall-cmd --add-service cockpit 
3. launch firefox with url : SERVER:9090
4. log-in
5. click on 'subscriptions' link in a left column

you see an error: 

"Couldn't get system subscription status. Please ensure subscription-manager is installed.

Unable to connect"


Expected results:

You should see a page of subscription plugin

it is related with dbus.

journalctl tells:

[root@jstavel-rhel7-server-01 ~]# journalctl -f
   -- Logs begin at St 2017-11-08 12:29:18 EST. --
   lis 08 14:35:01 jstavel-rhel7-server-01 systemd[1]: Started Session 449 of user root.
   lis 08 14:35:01 jstavel-rhel7-server-01 systemd[1]: Starting Session 449 of user root.
   lis 08 14:35:01 jstavel-rhel7-server-01 CROND[30656]: (root) CMD (/usr/bin/redhat-ddns-client &> /dev/null)
   lis 08 14:40:01 jstavel-rhel7-server-01 systemd[1]: Started Session 450 of user root.
   lis 08 14:40:01 jstavel-rhel7-server-01 systemd[1]: Starting Session 450 of user root.
   lis 08 14:40:01 jstavel-rhel7-server-01 CROND[30666]: (root) CMD (/usr/bin/redhat-ddns-client &> /dev/null)
   lis 08 14:41:55 jstavel-rhel7-server-01 dbus[516]: [system] Activating service name='com.redhat.SubscriptionManager' (using servicehelper)
   lis 08 14:41:55 jstavel-rhel7-server-01 dbus-daemon[516]: dbus[516]: [system] Activating service name='com.redhat.SubscriptionManager' (using servicehelper)
   lis 08 14:41:55 jstavel-rhel7-server-01 dbus[516]: [system] Activated service 'com.redhat.SubscriptionManager' failed: Failed to execute program /lib64/dbus-1/dbus-daemon-launch-helper: Success
   lis 08 14:41:55 jstavel-rhel7-server-01 dbus-daemon[516]: dbus[516]: [system] Activated service 'com.redhat.SubscriptionManager' failed: Failed to execute program /lib64/dbus-1/dbus-daemon-launch-helper: Success

Comment 2 Jan Stavel 2017-11-08 19:55:09 UTC
a version of RHEL7.5 (from latest-RHEL7)

[root@jstavel-rhel7-server-01 ~]# cat /etc/os-release 
   VERSION="7.5 (Maipo)"
   ID="rhel"
   ID_LIKE="fedora"
   VERSION_ID="7.5"
   ANSI_COLOR="0;31"
   HOME_URL="https://www.redhat.com/"
   BUG_REPORT_URL="https://bugzilla.redhat.com/"
   REDHAT_BUGZILLA_PRODUCT="Red Hat Enterprise Linux 7"
   REDHAT_BUGZILLA_PRODUCT_VERSION="7.5"
   REDHAT_SUPPORT_PRODUCT="Red Hat Enterprise Linux"
   REDHAT_SUPPORT_PRODUCT_VERSION="7.5 Beta"
   PRIVACY_POLICY_URL="http://www.redhat.com/en/about/privacy-policy"
   NAME="Red Hat Enterprise Linux Server"
   PRETTY_NAME="Red Hat Enterprise Linux Server 7.5 Beta (Maipo)"
   VARIANT="Server"
   VARIANT_ID="server"
   CPE_NAME="cpe:/o:redhat:enterprise_linux:7.5:beta:server"

Comment 3 Chris Snyder 2017-11-16 15:15:00 UTC
Jan,

Please retest with the subscription-manager-cockpit package which should be included in the RHEL75 composes.

Thanks,
Chris

Comment 4 Jan Stavel 2017-11-23 18:25:35 UTC
Hello Chris.
I've encountered a problem with DBus service SubscriptionManager

   busctl introspect com.redhat.SubscriptionManager --no-legend /EntitlementStatus

   Failed to introspect object /EntitlementStatus of service com.redhat.SubscriptionManager: Failed to execute program /lib64/dbus-1/dbus-daemon-launch-helper: Success


Cockpit Subscription Plugin uses 'check_status' of the /EntitlementStatus object.

It must be a problem with permissions or selinux context.

I'll provide more informations.

Comment 5 Jan Stavel 2017-11-23 18:52:56 UTC
Once I set SElinux to permissive cockpit works.

So the root of the problem is dbus service SubscriptionManager (some context needs to be set).

Is it enough for you Chris?

Comment 6 Jan Stavel 2017-11-23 20:19:46 UTC
Finally we can close this bug. 
I've enabled cockpit.socket systemd service and
rebooted the system and it works.

I do not know why.

I will pay attention to this problem and once it appears and I discover it more preciselly I will reopen this bug again.

Comment 7 Jan Stavel 2017-11-23 22:30:42 UTC
this seqence solves the problem.

root@jstavel-rhel7-server ~]# history

    1  systemctl enable cockpit.socket
    2  firewall-cmd --add-service cockpit
    3  firewall-cmd --add-service cockpit --permanent
    4  reboot


Note You need to log in before you can comment on or make changes to this bug.