Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511137 - show skipped pre-upgrade check items as skipped and not failed
Summary: show skipped pre-upgrade check items as skipped and not failed
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Foreman Maintain
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Anurag Patel
QA Contact: Katello QA List
URL:
Whiteboard:
: 1524249 (view as bug list)
Depends On:
Blocks: 1496794
TreeView+ depends on / blocked
 
Reported: 2017-11-08 18:17 UTC by sthirugn@redhat.com
Modified: 2018-04-03 14:57 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-26 19:16:51 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 22212 None None None 2018-01-10 10:20:17 UTC
Red Hat Bugzilla 1524249 None None None Never

Internal Links: 1524249

Description sthirugn@redhat.com 2017-11-08 18:17:39 UTC
Description of problem:
show skipped pre-upgrade check items as skipped and not failed

Version-Release number of selected component (if applicable):
rubygem-foreman_maintain-0.0.11-1.el7sat.noarch

How reproducible:
Always

Steps to Reproduce:
# foreman-maintain upgrade run --target-version 6.3 --whitelist disk-io 
Running preparation steps required to run the next scenarios
================================================================================
Procedures::Packages::Install: 
Loaded plugins: product-id, search-disabled-repos, subscription-manager
Package hdparm-9.43-5.el7.x86_64 already installed and latest version
No package fio available.
Nothing to do
                                                                      [OK]
--------------------------------------------------------------------------------

nning Checks before upgrading to Satellite 6.3
================================================================================
Check for paused tasks:                                               [OK]
--------------------------------------------------------------------------------
Check whether all services are running using hammer ping:             [OK]
--------------------------------------------------------------------------------
Check for running tasks:                                              [OK]
--------------------------------------------------------------------------------
Check for old tasks in paused/stopped state:                          [OK]
--------------------------------------------------------------------------------
Check for pending tasks which are safe to delete:                     [OK]
--------------------------------------------------------------------------------
Check for tasks in planning state:                                    [OK]
--------------------------------------------------------------------------------
Check for recommended disk speed of pulp, mongodb, pgsql dir.: 
| Finished                                                            [FAIL]    
Slow disk detected /var/lib/pulp mounted on /dev/mapper/rhel_ibm--x3250m4--07-root.
             Actual disk speed: 71 MB/sec
             Expected disk speed: 80 MB/sec.
--------------------------------------------------------------------------------


Actual results:
Check the command that I skipped `disk-io` but the output results showed:
Check for recommended disk speed of pulp, mongodb, pgsql dir.: 
| Finished                                                            [FAIL] 

Expected results:
Check for recommended disk speed of pulp, mongodb, pgsql dir.: 
| Finished                                                            [FAIL/SKIP] 

Additional info:

Comment 2 Anurag Patel 2018-01-10 14:11:05 UTC
*** Bug 1524249 has been marked as a duplicate of this bug. ***

Comment 3 sthirugn@redhat.com 2018-03-26 19:16:51 UTC
Since BZ is already used to address this problem, I am closing this.

*** This bug has been marked as a duplicate of bug 1525454 ***


Note You need to log in before you can comment on or make changes to this bug.