Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511099 - C&U data collection fails for GCE in 5.9
Summary: C&U data collection fails for GCE in 5.9
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Tomas Coufal
QA Contact: Nandini Chandra
URL:
Whiteboard: c&u:gce
: 1592216 (view as bug list)
Depends On:
Blocks: 1585821
TreeView+ depends on / blocked
 
Reported: 2017-11-08 16:53 UTC by Nandini Chandra
Modified: 2019-02-11 13:54 UTC (History)
9 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1585821 (view as bug list)
Environment:
Last Closed: 2019-02-11 13:54:44 UTC
Category: ---
Cloudforms Team: GCE


Attachments (Terms of Use)

Description Nandini Chandra 2017-11-08 16:53:29 UTC
Description of problem:
------------------------
Here's a snippet from evm.log:

[----] I, [2017-11-08T03:17:46.949171 #60889:5e1140]  INFO -- : MIQ(MiqQueue#delivered) Message id: [62811], State: [error], Delivered in [0.266723148] seconds

[----] I, [2017-11-08T03:17:46.965786 #60889:5e1140]  INFO -- : MIQ(ManageIQ::Providers::Google::CloudManager::MetricsCollectorWorker::Runner#get_message_via_drb) Message id: [62813], MiqWorker id: [56], Zone: [default], Role: [ems_metrics_collector], Server: [], Ident: [google], Target id: [], Instance id: [1015], Task id: [], Command: [ManageIQ::Providers::Google::CloudManager::Vm.perf_capture_realtime], Timeout: [600], Priority: [100], State: [dequeue], Deliver On: [], Data: [], Args: [2017-11-08 00:00:00 UTC], Dequeued in: [23.72007165] seconds

[----] I, [2017-11-08T03:17:46.966050 #60889:5e1140]  INFO -- : MIQ(MiqQueue#deliver) Message id: [62813], Delivering...

[----] I, [2017-11-08T03:17:46.971803 #60889:5e1140]  INFO -- : MIQ(ManageIQ::Providers::Google::CloudManager::Vm#just_perf_capture) [realtime] Capture for ManageIQ::Providers::Google::CloudManager::Vm name: [cu-24x7], id: [1015], start_time: [2017-11-08 00:00:00 UTC]...

[----] I, [2017-11-08T03:17:46.980027 #60889:5e1140]  INFO -- : MIQ(ManageIQ::Providers::Google::CloudManager#with_provider_connection) Connecting through ManageIQ::Providers::Google::CloudManager: [gce_central]
I, [2017-11-08T03:17:47.099524 #60898]  INFO -- : Exception in realtime_block :total_time - Timings: {:capture_state=>0.002985239028930664, :total_time=>0.28063344955444336}

[----] E, [2017-11-08T03:17:47.099851 #60898:5e1140] ERROR -- : MIQ(MiqQueue#deliver) Message id: [62812], Error: [Not Found]

[----] E, [2017-11-08T03:17:47.100188 #60898:5e1140] ERROR -- : [Google::APIClient::ClientError]: Not Found  Method:[block in method_missing]

[----] E, [2017-11-08T03:17:47.100309 #60898:5e1140] ERROR -- : /opt/rh/cfme-gemset/gems/google-api-client-0.8.6/lib/google/api_client.rb:662:in `block (2 levels) in execute!'
/opt/rh/cfme-gemset/gems/retriable-1.4.1/lib/retriable/retry.rb:27:in `perform'
/opt/rh/cfme-gemset/gems/retriable-1.4.1/lib/retriable.rb:15:in `retriable'
/opt/rh/cfme-gemset/gems/google-api-client-0.8.6/lib/google/api_client.rb:645:in `block in execute!'
/opt/rh/cfme-gemset/gems/retriable-1.4.1/lib/retriable/retry.rb:27:in `perform'
/opt/rh/cfme-gemset/gems/retriable-1.4.1/lib/retriable.rb:15:in `retriable'
/opt/rh/cfme-gemset/gems/google-api-client-0.8.6/lib/google/api_client.rb:636:in `execute!'
/opt/rh/cfme-gemset/gems/google-api-client-0.8.6/lib/google/api_client.rb:368:in `discovery_document'
/opt/rh/cfme-gemset/gems/google-api-client-0.8.6/lib/google/api_client.rb:413:in `discovered_api'
/opt/rh/cfme-gemset/gems/fog-google-0.5.4/lib/fog/google/monitoring/real.rb:15:in `initialize'
/opt/rh/cfme-gemset/gems/fog-core-1.45.0/lib/fog/core/service.rb:115:in `new'
/opt/rh/cfme-gemset/gems/fog-core-1.45.0/lib/fog/core/service.rb:115:in `new'
/opt/rh/cfme-gemset/bundler/gems/manageiq-providers-google-15724aa660aa/app/models/manageiq/providers/google/manager_mixin.rb:56:in `raw_connect'
/opt/rh/cfme-gemset/bundler/gems/manageiq-providers-google-15724aa660aa/app/models/manageiq/providers/google/manager_mixin.rb:27:in `connect'
/var/www/miq/vmdb/app/models/ext_management_system.rb:385:in `with_provider_connection'
/opt/rh/cfme-gemset/bundler/gems/manageiq-providers-google-15724aa660aa/app/models/manageiq/providers/google/cloud_manager/metrics_capture.rb:95:in `perf_collect_metrics'
/var/www/miq/vmdb/app/models/metric/ci_mixin/capture.rb:6:in `perf_collect_metrics'
/var/www/miq/vmdb/app/models/metric/ci_mixin/capture.rb:193:in `block in just_perf_capture'
/opt/rh/cfme-gemset/bundler/gems/manageiq-gems-pending-9e85dfe3ef20/lib/gems/pending/util/extensions/miq-benchmark.rb:11:in `realtime_store'
/opt/rh/cfme-gemset/bundler/gems/manageiq-gems-pending-9e85dfe3ef20/lib/gems/pending/util/extensions/miq-benchmark.rb:35:in `realtime_block'
/var/www/miq/vmdb/app/models/metric/ci_mixin/capture.rb:189:in `just_perf_capture'
/var/www/miq/vmdb/app/models/metric/ci_mixin/capture.rb:135:in `perf_capture'
/var/www/miq/vmdb/app/models/metric/ci_mixin/capture.rb:117:in `perf_capture_realtime'
/var/www/miq/vmdb/app/models/miq_queue.rb:449:in `block in dispatch_method'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:91:in `block in timeout'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:33:in `block in catch'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:33:in `catch'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:33:in `catch'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:106:in `timeout'
/var/www/miq/vmdb/app/models/miq_queue.rb:448:in `dispatch_method'
/var/www/miq/vmdb/app/models/miq_queue.rb:425:in `block in deliver'
/var/www/miq/vmdb/app/models/user.rb:252:in `with_user_group'
/var/www/miq/vmdb/app/models/miq_queue.rb:425:in `deliver'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:105:in `deliver_queue_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:134:in `deliver_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:152:in `block in do_work'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:146:in `loop'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:146:in `do_work'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:329:in `block in do_work_loop'



Version-Release number of selected component (if applicable):
--------------------------------------------------------------
5.9.0.5


How reproducible:
----------------
Always


Steps to Reproduce:
-------------------
1.Manage GCE and enable C&U collection for it.


Actual results:
---------------
No C&U data from GCE


Expected results:
-----------------
C&U data should be successfully fetched from GCE.


Additional info:
----------------

Comment 3 Nandini Chandra 2017-11-29 18:52:15 UTC
This issue is seen in 5.7.4.1 as well.

Comment 7 Tomas Coufal 2018-04-06 09:02:25 UTC
This will be fixed within fog-google upgrade.

Comment 8 Tomas Coufal 2018-05-25 08:03:25 UTC
PRs providing fog-google upgrade are finally available to review

https://github.com/ManageIQ/manageiq-providers-google/pull/54
https://github.com/ManageIQ/manageiq/pull/17258

Comment 11 Bronagh Sorota 2018-06-18 15:58:04 UTC
*** Bug 1592216 has been marked as a duplicate of this bug. ***

Comment 12 Nandini Chandra 2018-07-17 19:49:22 UTC
verified in 5.10.0.4


Note You need to log in before you can comment on or make changes to this bug.