Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511075 - vdo manpage: Wrong maximum --vdoPhysicalThreads count
Summary: vdo manpage: Wrong maximum --vdoPhysicalThreads count
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: vdo
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Ken Raeburn
QA Contact: Jakub Krysl
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-08 15:46 UTC by Jakub Krysl
Modified: 2019-03-06 01:00 UTC (History)
3 users (show)

Fixed In Version: 6.1.0.45
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 15:47:46 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:0871 None None None 2018-04-10 15:48:08 UTC

Description Jakub Krysl 2017-11-08 15:46:51 UTC
Description of problem:
vdo manpage allows maximum of 100 physical threads. Both vdo --help and actual results when trying to create vdo with more threads than 16 forbit values larger than 16.

Version-Release number of selected component (if applicable):
vdo-6.1.0.34-8

How reproducible:
100%

Steps to Reproduce:
1. man vdo
2. vdo --help
3. vdo create --device DEVICE --name NAME --vdoPhysicalThreads 100

Actual results:
manpage:
       --vdoPhysicalThreads=thread count
              Specifies the number of threads across which to subdivide parts of the VDO processing based on physical block addresses. Each additional thread after the first will use an additional 10 MB of
              RAM. The default is 1; the value must be at least 0 and less than or equal to 100. vdoPhysicalThreads, vdoHashZonesThreads and vdoLogicalThreads must be either all zero or all non-zero.

help:
    --vdoPhysicalThreads=<threadCount>              
                        Specifies the number of threads across which to                                  
                        subdivide parts of the VDO processing based on                                   
                        physical block addresses. The default is 1; the value                            
                        must be at least 0 and less than or equal to 16.                                 
                        vdoPhysicalThreads, vdoHashZonesThreads and                                      
                        vdoLogicalThreads must be either all zero or all non-                            
                        zero. 

vdo create command:
vdo: error: option --vdoPhysicalThreads: must be an integer at least 0 and less than or equal to 16

Expected results:
Fixed VDO manpage

Additional info:

Comment 2 Ken Raeburn 2017-11-10 23:52:09 UTC
Man page corrected.

Comment 4 Jakub Krysl 2017-11-14 14:54:12 UTC
Tested with vdo-6.1.0.46-9, manpage:

       --vdoPhysicalThreads=thread count
              Specifies the number of threads across which to subdivide parts of  the  VDO  processing
              based  on  physical  block addresses. Each additional thread after the first will use an
              additional 10 MB of RAM. The default is 1; the value must be at least 0 and less than or
              equal  to  16.  vdoPhysicalThreads,  vdoHashZonesThreads  and  vdoLogicalThreads must be
              either all zero or all non-zero.

Comment 7 errata-xmlrpc 2018-04-10 15:47:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0871


Note You need to log in before you can comment on or make changes to this bug.