Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511042 - 'vdo: ERROR - Insufficient block map cache for vdo' with --vdoLogicalThreads HIGH, missing info in manpage about this link
Summary: 'vdo: ERROR - Insufficient block map cache for vdo' with --vdoLogicalThreads ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: vdo
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Ken Raeburn
QA Contact: Jakub Krysl
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-08 15:25 UTC by Jakub Krysl
Modified: 2019-03-06 01:32 UTC (History)
3 users (show)

Fixed In Version: 6.1.0.51
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 15:47:46 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:0871 None None None 2018-04-10 15:48:08 UTC

Description Jakub Krysl 2017-11-08 15:25:57 UTC
Description of problem:
There is missing information in manpage about link between block map cache size and logical thread count. The default 128MB block map cache can support up to 8 logical threads (try-error), so to have more logical threads, user also has to increase block map cache size. I assume this could be done automatically, increasing default block map cache size if it is not large enough. But never the less this information should be in manpage.


Version-Release number of selected component (if applicable):
vdo-6.1.0.34-8

How reproducible:
100%

Steps to Reproduce:
1. vdo create --device DEVICE --name NAME --vdoLogicalThreads 100

Actual results:
vdo: ERROR - Insufficient block map cache for vdo
No hint in manpage about this

Expected results:
vdo: ERROR - Insufficient block map cache for vdo / or VDO succesfully creted with larger block map cache size
Information in manpage about this link

Additional info:

Comment 2 Ken Raeburn 2017-11-13 23:18:59 UTC
The "vdo" man page does mention this under the --blockMapCacheSize option, but the doc for --vdoLogicalThreads doesn't touch on it. Easy enough to fix...

Comment 4 Jakub Krysl 2017-11-21 13:19:55 UTC
vdo-6.1.0.55-10

manpage:
--blockMapCacheSize "The cache must be at least 16MB per logical thread. Note that there is a memory overhead of 15%."
--vdoLogicalThreads "A logical thread count over 8 will require explicitly specifying a sufficiently large block map cache size, as well."

--help:
--vdoLogicalThreads "A logical thread count over 8 will require explicitly specifying a sufficiently large block map cache size, as well."

The info about logical threads is missing at --helps --blockMapCacheSize, but it is in manpage, which is enough with this specific info. There is enough info at --vdoLogicalThreads in both manpage and --help.

Comment 7 errata-xmlrpc 2018-04-10 15:47:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0871


Note You need to log in before you can comment on or make changes to this bug.