Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511025 - Remove storage domain dialog box has a dropDownList-checkBox related issue
Summary: Remove storage domain dialog box has a dropDownList-checkBox related issue
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.0
Hardware: x86_64
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.2.0
: ---
Assignee: shani
QA Contact: Yosi Ben Shimon
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-08 15:03 UTC by Yosi Ben Shimon
Modified: 2017-12-20 10:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 10:41:28 UTC
oVirt Team: Storage
rule-engine: ovirt-4.2+


Attachments (Terms of Use)
screenshot (deleted)
2017-11-08 15:03 UTC, Yosi Ben Shimon
no flags Details
bug_1511025 (deleted)
2017-11-23 16:05 UTC, shani
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 84591 master MERGED webadmin: Disable the hosts list when pop-up opens 2017-11-23 16:02:22 UTC

Description Yosi Ben Shimon 2017-11-08 15:03:44 UTC
Created attachment 1349478 [details]
screenshot

Description of problem:
When i check the checkBox in the format domain, the Host to be used dropDownList stays enabled. And when i unchecked it, the Host to be used dropDownList is disabled.

Version-Release number of selected component (if applicable):
d/s rhvm-4.2.0-0.4.master.el7

How reproducible:
100%

Steps to Reproduce:
1. Open 'remove storage domain' dialog box under storage domains.
2. Check 'format domain...' checkbox
3. Uncheck 'format domain...' checkbox

Actual results:
Host to be used dropDownList is disabled

Expected results:
Host to be used dropDownList enabled

Additional info:

Comment 1 shani 2017-11-23 15:25:28 UTC
The expected behaviour should be:
When format is chosen, a host should be selected from the drop list, therefore it should be enabled.
Otherwise, the format is unchecked and the hosts' drop list should be disabled.

The undesired behaviour is when the dialogue is opened: the format is unchecked and the drop-list is enabled.

Comment 2 shani 2017-11-23 16:05:21 UTC
Created attachment 1358310 [details]
bug_1511025

Comment 3 Yosi Ben Shimon 2017-12-12 12:57:32 UTC
'Host to be used' dropDownList is now enabled when the 'Format Domain' checkbox is checked and vise versa.

Tested using:

rhvm-4.2.0-0.6.el7.noarch
vdsm-4.20.9-27.gitb8f880e.el7.centos.x86_64

Comment 4 Sandro Bonazzola 2017-12-20 10:41:28 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.