Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510898 - Tagged Datastores in chargeback storage don't work
Summary: Tagged Datastores in chargeback storage don't work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting
Version: 5.8.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: GA
: 5.10.0
Assignee: Libor Pichler
QA Contact: Nandini Chandra
URL:
Whiteboard:
Depends On:
Blocks: 1526039 1526040
TreeView+ depends on / blocked
 
Reported: 2017-11-08 12:19 UTC by Edu Alcaniz
Modified: 2018-06-21 20:33 UTC (History)
9 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1526039 1526040 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:33:51 UTC
Category: Bug
Cloudforms Team: CFME Core


Attachments (Terms of Use)
Report_1.PNG (deleted)
2017-11-08 12:21 UTC, Edu Alcaniz
no flags Details
Report_2.PNG (deleted)
2017-11-08 12:21 UTC, Edu Alcaniz
no flags Details
Assignments_-_Compute_-_Tagged_instances_-_Basic_of_OSP.PNG (deleted)
2017-11-08 12:21 UTC, Edu Alcaniz
no flags Details
Assignments_-_STORAGE_-_Tagged_Datastores.PNG (deleted)
2017-11-08 12:21 UTC, Edu Alcaniz
no flags Details
Storage_with_tag.PNG (deleted)
2017-11-08 12:22 UTC, Edu Alcaniz
no flags Details

Description Edu Alcaniz 2017-11-08 12:19:31 UTC
Description of problem:

When customer created a new Tag Category called "Type of Storage in OSP" with 3 tags called "Disk hiperf", "Disk SSD" and "Disk standard". I created this because we need three type of costs depend type of disk used.

Then, they tagged all disks depends its disk type (IMAGE_1) and they created three types of Rates in "Cloud Intel -> Chargeback -> Rates -> Storage".

However, when they assigned this tags in "Cloud Intel -> Chargeback -> Assignments -> Storage" (IMAGE_2), I saw in reports that all storages cost disappeared.

To locate the bug, they assigned same tags to "Compute" and when they saw the reports, the funcionality was working correctly and they could see cost depending the tags (IMAGE_3)

they think that chargeback only can see tags asociate with compute but not with storage (see "Produban Tag Type of Storage in OSP" column).


Version-Release number of selected component (if applicable):


How reproducible:
CFME 4.5

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Edu Alcaniz 2017-11-08 12:21:06 UTC
Created attachment 1349420 [details]
Report_1.PNG

Comment 3 Edu Alcaniz 2017-11-08 12:21:21 UTC
Created attachment 1349421 [details]
Report_2.PNG

Comment 4 Edu Alcaniz 2017-11-08 12:21:40 UTC
Created attachment 1349422 [details]
Assignments_-_Compute_-_Tagged_instances_-_Basic_of_OSP.PNG

Comment 5 Edu Alcaniz 2017-11-08 12:21:55 UTC
Created attachment 1349423 [details]
Assignments_-_STORAGE_-_Tagged_Datastores.PNG

Comment 6 Edu Alcaniz 2017-11-08 12:22:14 UTC
Created attachment 1349424 [details]
Storage_with_tag.PNG

Comment 7 Dave Johnson 2017-11-09 15:45:12 UTC
Nandini, what does this look like for 5.9.0?

Comment 9 Dave Johnson 2017-11-21 13:41:29 UTC
Edu, I would say yes it will be part of 5.8.3 but no promises.  I am marking it a blocker.


Note You need to log in before you can comment on or make changes to this bug.