Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510881 - nothing provides libcryptsetup.so.4()(64bit) needed by systemd-235-3.fc28
Summary: nothing provides libcryptsetup.so.4()(64bit) needed by systemd-235-3.fc28
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: cryptsetup
Version: rawhide
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Milan Broz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-08 11:38 UTC by Lukas Slebodnik
Modified: 2017-11-09 10:42 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-09 10:42:44 UTC


Attachments (Terms of Use)

Description Lukas Slebodnik 2017-11-08 11:38:43 UTC
cryptsetup was rebased in rawhide to cryptsetup-2.0.0-0.2.fc28
and part of this upgrade there was a SONAME bump.

And therefore there are many conflicts in rawhide due to many dependencies on systemd which still depends on libcryptsetup.so.4

e.g. Failed build of atomic:
https://kojipkgs.fedoraproject.org//work/tasks/8416/22978416/root.log
DEBUG util.py:439:  Error: 
DEBUG util.py:439:   Problem: package policycoreutils-python3-2.7-4.fc28.x86_64 requires libcgroup, but none of the providers can be installed
DEBUG util.py:439:    - package libcgroup-0.41-13.fc27.x86_64 requires systemd, but none of the providers can be installed
DEBUG util.py:439:    - conflicting requests
DEBUG util.py:439:    - nothing provides libcryptsetup.so.4()(64bit) needed by systemd-235-3.fc28.x86_64
DEBUG util.py:577:  Child return code was: 1


I can see that you tried to rebuild systemd with new cryptsetup but it failed
https://koji.fedoraproject.org/koji/buildinfo?buildID=996049

DEBUG util.py:439:  Error: 
DEBUG util.py:439:   Problem 1: package dbus-devel-1:1.12.0-1.fc28.x86_64 requires dbus = 1:1.12.0-1.fc28, but none of the providers can be installed
DEBUG util.py:439:    - package dbus-1:1.12.0-1.fc28.x86_64 requires systemd, but none of the providers can be installed
DEBUG util.py:439:    - conflicting requests
DEBUG util.py:439:    - nothing provides libcryptsetup.so.4()(64bit) needed by systemd-235-3.fc28.x86_64
DEBUG util.py:439:   Problem 2: package gnutls-dane-3.6.1-2.fc28.x86_64 requires libunbound.so.2()(64bit), but none of the providers can be installed
DEBUG util.py:439:    - package gnutls-devel-3.6.1-2.fc28.x86_64 requires libgnutls-dane.so.0()(64bit), but none of the providers can be installed
DEBUG util.py:439:    - package unbound-libs-1.6.7-1.fc28.x86_64 requires systemd, but none of the providers can be installed
DEBUG util.py:439:    - conflicting requests
DEBUG util.py:439:    - nothing provides libcryptsetup.so.4()(64bit) needed by systemd-235-3.fc28.x86_64
DEBUG util.py:439:   Problem 3: package device-mapper-devel-1.02.145-1.fc28.x86_64 requires device-mapper = 1.02.145-1.fc28, but none of the providers can be installed
DEBUG util.py:439:    - package cryptsetup-devel-2.0.0-0.2.fc28.x86_64 requires device-mapper-devel, but none of the providers can be installed
DEBUG util.py:439:    - package device-mapper-1.02.145-1.fc28.x86_64 requires systemd >= 189-3, but none of the providers can be installed
DEBUG util.py:439:    - conflicting requests
DEBUG util.py:439:    - nothing provides libcryptsetup.so.4()(64bit) needed by systemd-235-3.fc28.x86_64
DEBUG util.py:439:   Problem 4: package gnutls-devel-3.6.1-2.fc28.x86_64 requires libgnutls-dane.so.0()(64bit), but none of the providers can be installed
DEBUG util.py:439:    - package gnutls-dane-3.6.1-2.fc28.x86_64 requires libunbound.so.2()(64bit), but none of the providers can be installed
DEBUG util.py:439:    - package libmicrohttpd-devel-1:0.9.55-3.fc27.x86_64 requires pkgconfig(gnutls), but none of the providers can be installed
DEBUG util.py:439:    - package unbound-libs-1.6.7-1.fc28.x86_64 requires systemd, but none of the providers can be installed
DEBUG util.py:439:    - conflicting requests
DEBUG util.py:439:    - nothing provides libcryptsetup.so.4()(64bit) needed by systemd-235-3.fc28.x86_64
DEBUG util.py:577:  Child return code was: 1

Comment 1 Lukas Slebodnik 2017-11-08 11:41:06 UTC
sh# dnf repoquery --whatrequires "libcryptsetup.so.4()(64bit)"
Last metadata expiration check: 0:12:33 ago on Wed 08 Nov 2017 12:25:53 PM CET.
clevis-udisks2-0:7-1.fc28.x86_64
cryptsetup-0:1.7.5-5.fc28.x86_64
cryptsetup-devel-0:1.7.5-5.fc28.x86_64
cryptsetup-python3-0:1.7.5-5.fc28.x86_64
cryptsetup-reencrypt-0:1.7.5-5.fc28.x86_64
deo-disks-0:0.5.1-2.fc24.x86_64
libblockdev-crypto-0:2.14-1.fc28.x86_64
libluksmeta-0:8-1.fc28.x86_64
luksmeta-0:8-1.fc28.x86_64
pam_mount-0:2.16-1.fc28.x86_64
python2-cryptsetup-0:1.7.5-5.fc28.x86_64
python2-volume_key-0:0.3.9-16.fc28.x86_64
systemd-0:235-3.fc28.x86_64
systemd-tests-0:235-3.fc28.x86_64
systemd-udev-0:235-3.fc28.x86_64
veritysetup-0:1.7.5-5.fc28.x86_64
volume_key-0:0.3.9-16.fc28.x86_64
volume_key-libs-0:0.3.9-16.fc28.x86_64
zulucrypt-console-0:5.2.0-3.fc27.x86_64
zulucrypt-libs-0:5.2.0-3.fc27.x86_64

sh# dnf repoquery --whatrequires "libcryptsetup.so.12()(64bit)"
Last metadata expiration check: 0:13:27 ago on Wed 08 Nov 2017 12:25:53 PM CET.

Feel free to move this BZ to cryptsetup. Or ask some proven packager to rebuild all packages with new cryptsetup :-)

But it would be good to unblock building packages in koji which requires systemd

Comment 2 Ondrej Kozina 2017-11-08 16:36:36 UTC
Yeah, I missed the fact systemd requires itself for rebuild so I did break it for a short time. This should be resolved with cryptsetup-2.0.0-0.3.fc28 and subsequent rolling rebuilds.

Comment 3 Zbigniew Jędrzejewski-Szmek 2017-11-08 16:49:50 UTC
Yeah, we have a circular dependency on dbus. I forgot that this would be relevant here. Anyway, it's fixed now by the cryptsetup build with both symbols. Thanks for taking care of that.

Comment 4 Lukas Slebodnik 2017-11-09 09:03:07 UTC
(In reply to Ondrej Kozina from comment #2)
> Yeah, I missed the fact systemd requires itself for rebuild so I did break
> it for a short time. This should be resolved with cryptsetup-2.0.0-0.3.fc28
> and subsequent rolling rebuilds.

Thank you for temporary workaround :-)
https://src.fedoraproject.org/rpms/cryptsetup/c/245fb0ba8bb6e9827f03911f89c58621774b552c?branch=master

But I would prefer to rebuild all required packages with new symbols from libcryptsetup.so.12(CRYPTSETUP_2.0)(64bit).

Or do the same as it was done with openssl-1.1 and compat-openssl10.

Comment 5 Milan Broz 2017-11-09 09:23:43 UTC
I think all packages are rebuilt already. Do you still see something that is linked to the old library?
(Maybe just wait for compose repo update from yesterday.)

Next rebuild will remove old library completely but AFAIK nothing should use it now.

Comment 6 Lukas Slebodnik 2017-11-09 10:35:28 UTC
sh# (In reply to Milan Broz from comment #5)
> I think all packages are rebuilt already. Do you still see something that is
> linked to the old library?
> (Maybe just wait for compose repo update from yesterday.)
>

It's possible that I need to wait

sh# rm -rf /var/cache/dnf/*
sh# dnf check-update
sh# dnf repoquery --whatrequires "libcryptsetup.so.4()(64bit)"
Last metadata expiration check: 0:00:41 ago on Thu 09 Nov 2017 11:32:26 AM CET.
clevis-udisks2-0:7-1.fc28.x86_64
cryptsetup-0:1.7.5-5.fc28.x86_64
cryptsetup-devel-0:1.7.5-5.fc28.x86_64
cryptsetup-python3-0:1.7.5-5.fc28.x86_64
cryptsetup-reencrypt-0:1.7.5-5.fc28.x86_64
deo-disks-0:0.5.1-2.fc24.x86_64
libblockdev-crypto-0:2.14-1.fc28.x86_64
libluksmeta-0:8-1.fc28.x86_64
luksmeta-0:8-1.fc28.x86_64
pam_mount-0:2.16-1.fc28.x86_64
python2-cryptsetup-0:1.7.5-5.fc28.x86_64
python2-volume_key-0:0.3.9-16.fc28.x86_64
systemd-0:235-3.fc28.x86_64
systemd-tests-0:235-3.fc28.x86_64
systemd-udev-0:235-3.fc28.x86_64
veritysetup-0:1.7.5-5.fc28.x86_64
volume_key-0:0.3.9-16.fc28.x86_64
volume_key-libs-0:0.3.9-16.fc28.x86_64
zulucrypt-console-0:5.2.0-3.fc27.x86_64
zulucrypt-libs-0:5.2.0-3.fc27.x86_64
 
> Next rebuild will remove old library completely but AFAIK nothing should use
> it now.

+1

Comment 7 Ondrej Kozina 2017-11-09 10:42:44 UTC
Good. We'll drop the old library when we're sure nothing in compose depend on it.


Note You need to log in before you can comment on or make changes to this bug.