Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510874 - print-backtrace.sh failing with cpio version 2.11 or older
Summary: print-backtrace.sh failing with cpio version 2.11 or older
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: unclassified
Version: mainline
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Prashant Dhange
QA Contact: Rahul Hinduja
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-08 11:20 UTC by Prashant Dhange
Modified: 2018-03-15 11:20 UTC (History)
7 users (show)

Fixed In Version: glusterfs-4.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-15 11:20:03 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Prashant Dhange 2017-11-08 11:20:11 UTC
Description of problem:
When print-backtrace.sh tried with older cpio version, we failed to get proper call trace as cpio 2.11 or older version seems to be not having -D or --directory option.

Version-Release number of selected component (if applicable):
# cpio --version

How reproducible:
Frequently

Steps to Reproduce:
1. Get print-backtrace.sh script 
2. Use RHEL 6/7 having cpio version 2.11 or less
3. Run # sh print-backtrace.sh /root/01966985/glusterfs-debuginfo-3.8.4-18.el7.x86_64.rpm bt.log

Actual results:
cpio command failing with unrecognised error 

Expected results:
print-backtrace.sh should work with all cpio version


Additional info:
# sh print-backtrace.sh /root/01966985/glusterfs-debuginfo-3.8.4-18.el7.x86_64.rpm bt.log 
cpio: unrecognized option '--directory=glusterfs-debuginfo-3.8.4-18.el7.x86_64'
Try `cpio --help' or `cpio --usage' for more information.
eu-addr2line: /root/01966985/glusterfs-debuginfo-3.8.4-18.el7.x86_64/usr/lib/debug/usr/lib64/glusterfs/3.8.4/xlator/features/locks.so.debug: No such file or directory
/usr/lib64/glusterfs/3.8.4/xlator/features/locks.so(+0x18905)[0x7f9ec991b905] 
eu-addr2line: /root/01966985/glusterfs-debuginfo-3.8.4-18.el7.x86_64/usr/lib/debug/usr/lib64/glusterfs/3.8.4/xlator/features/locks.so.debug: No such file or directory
/usr/lib64/glusterfs/3.8.4/xlator/features/locks.so(+0x15722)[0x7f9ec9918722] 
eu-addr2line: /root/01966985/glusterfs-debuginfo-3.8.4-18.el7.x86_64/usr/lib/debug/usr/lib64/glusterfs/3.8.4/xlator/protocol/server.so.debug: No such file or directory
/usr/lib64/glusterfs/3.8.4/xlator/protocol/server.so(+0xfc28)[0x7f9ec3dc7c28] 
eu-addr2line: /root/01966985/glusterfs-debuginfo-3.8.4-18.el7.x86_64/usr/lib/debug/usr/lib64/glusterfs/3.8.4/xlator/protocol/server.so.debug: No such file or directory
/usr/lib64/glusterfs/3.8.4/xlator/protocol/server.so(+0x7d70)[0x7f9ec3dbfd70] 
eu-addr2line: /root/01966985/glusterfs-debuginfo-3.8.4-18.el7.x86_64/usr/lib/debug/usr/lib64/glusterfs/3.8.4/rpc-transport/socket.so.debug: No such file or directory
/usr/lib64/glusterfs/3.8.4/rpc-transport/socket.so(+0x9754)[0x7f9ecd57d754] 
eu-addr2line: /root/01966985/glusterfs-debuginfo-3.8.4-18.el7.x86_64/usr/lib/debug/lib64/libglusterfs.so.0.debug: No such file or directory
/lib64/libglusterfs.so.0(+0x83770)[0x7f9ed8d1d770]

Comment 2 Prashant Dhange 2017-11-08 11:29:56 UTC
Patch submitted : https://review.gluster.org/#/c/18696/

Comment 4 Amar Tumballi 2017-11-20 18:19:44 UTC
looks fine. Just that the bug id is given from RHGS, instead of community project GlusterFS.

Comment 5 Worker Ant 2017-11-26 23:05:41 UTC
COMMIT: https://review.gluster.org/18696 committed in master by  with a commit message- extras/devel-tools: Fix print-backtrace script

Problem:
If cpio version is less 2.11 then cpio command failing with
unrecognised option --directory.

Solution:
Check the cpio version and run rpm2cpio/cpio with or without
-D or --directory option.

Fixes : #359
Change-Id: Ibd440207231807dab1b58291ab661857094f1a4a
BUG: 1510874
Signed-off-by: Prashant D <pdhange@redhat.com>

Comment 6 Shyamsundar 2018-03-15 11:20:03 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.0.0, please open a new bug report.

glusterfs-4.0.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-March/000092.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.