Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510871 - Boot from image (Create new Volume) Failed [NEEDINFO]
Summary: Boot from image (Create new Volume) Failed
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-glance
Version: 11.0 (Ocata)
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Cyril Roelandt
QA Contact: Mike Abrams
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-08 11:04 UTC by Muhammad Usman
Modified: 2018-01-17 14:59 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-17 14:59:29 UTC
abishop: needinfo? (m.usmanayub)
cschwede: needinfo? (m.usmanayub)


Attachments (Terms of Use)
volume.log (deleted)
2017-11-08 11:04 UTC, Muhammad Usman
no flags Details

Description Muhammad Usman 2017-11-08 11:04:05 UTC
Created attachment 1349389 [details]
volume.log

Description of problem:
I have used RHOSP to deploy the overcloud environment based on Ocata release.

I have attached Huawei Storage as the Cinder Volume backend. Glance is using file as backend.

I am getting successful result when trying to create an empty volume but when trying to launching an instance by selecting boot from image and creating a new volume I am getting the following error in volume.log (Attached)



The volume backend driver is properly initialized since I can create an empty volume and also there are no logs being generated on the storage for this operation

Need some guidance.

Version-Release number of selected component (if applicable):
cinder version: 1.11.0
glance version: 2.6.0

How reproducible:
N/A

Steps to Reproduce:
1. 
2.
3.

Actual results:
Volume Attach failed

Expected results:
Volume attach successful

Additional info:
Error appearing in volume.log is attached

Comment 1 Alan Bishop 2017-11-15 12:48:37 UTC
Having the volume log is great, but it doesn't provide all the information necessary to understand what is happening. Please enable DEBUG logs ("DEBUG = true" in cinder.conf), and capture an sosreport so that we have all the logs.

Comment 2 Gorka Eguileor 2017-11-22 11:30:10 UTC
This could be a Cinder configuration issue (glance_api_servers and glance_api_version could be incorrect), but like Alan mentioned we need the SOS report.

Comment 3 Christian Schwede (cschwede) 2017-11-22 14:16:25 UTC
Muhammad, can you please share the debug logs and sosreport as asked by Alan?

Comment 4 Muhammad Usman 2017-11-22 14:40:34 UTC
I am sorry for the delay I haven't been able to collect the debug logs but I found the reason which is that the glance is using file as the backend and there are 3 controllers so when uploading an image to glance it gets written to one of the controllers and when trying to create an Instance every 3rd request is successful due to the fact that it is sending round-robin requests to all the controllers and when it finds the image on the controller on which the image is present the creation is successful. 

So I believe the issue is with glance not cinder.

Comment 6 Sean Cohen 2018-01-17 14:59:29 UTC
(In reply to Muhammad Usman from comment #0)

Hello Muhammad,
Given that this is invalid configuration closing as wontfix,
Feel free to re-open with account information with a proper customer case.
Thanks,
Sean


Note You need to log in before you can comment on or make changes to this bug.