Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510865 - python-ldap is not a dependency of 389-ds-base
Summary: python-ldap is not a dependency of 389-ds-base
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: mreynolds
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-08 10:48 UTC by Marc Muehlfeld
Modified: 2018-04-10 14:22 UTC (History)
3 users (show)

Fixed In Version: 389-ds-base-1.3.7.5-10.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 14:21:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0811 None None None 2018-04-10 14:22:03 UTC

Description Marc Muehlfeld 2017-11-08 10:48:22 UTC
Description of problem:
In RHEL 7.5 beta, if you install Directory Server, the python-ldap package is not installed as a dependency. However, the new ds-replcheck script provided by 389-ds-base needs it.



Version-Release number of selected component (if applicable):
389-ds-base-1.3.7.5-9.el7.x86_64



How reproducible:
Always.



Steps to Reproduce:
1. Install 389-ds-base
2. Run ds-replcheck



Actual results:
# ds-replcheck --help
Traceback (most recent call last):
  File "/usr/bin/ds-replcheck", line 14, in <module>
    import ldap
ImportError: No module named ldap



Expected results:
Command should work.
(install python-ldap to fix the problem.)


Additional info:
Add python-ldap as a dependency to 389-ds-base to fix the problem

Comment 3 Viktor Ashirov 2017-11-21 16:43:20 UTC
Build tested:
389-ds-base-1.3.7.5-10.el7.x86_64

Latest build pulls python-ldap:
# repoquery --requires --resolve  389-ds-base  | grep python-ldap 
python-ldap-0:2.4.15-2.el7.x86_64

ds-replcheck doesn't throw error.

Marking as VERIFIED, SanityOnly.

Comment 6 errata-xmlrpc 2018-04-10 14:21:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0811


Note You need to log in before you can comment on or make changes to this bug.