Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510858 - Failed to install the ovirt-node-ng 4.1.7 (ovirt-node-ng-installer-ovirt-4.1-2017110715.iso)
Summary: Failed to install the ovirt-node-ng 4.1.7 (ovirt-node-ng-installer-ovirt-4.1-...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-node
Classification: oVirt
Component: Installation & Update
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
urgent vote
Target Milestone: ovirt-4.1.7
: 4.1
Assignee: Yuval Turgeman
QA Contact: cshao
URL:
Whiteboard:
: 1511006 (view as bug list)
Depends On:
Blocks: 1496762
TreeView+ depends on / blocked
 
Reported: 2017-11-08 10:26 UTC by cshao
Modified: 2017-11-18 01:36 UTC (History)
16 users (show)

Fixed In Version: ovirt-node-ng-installer-ovirt-4.1-2017110820.iso
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1514625 (view as bug list)
Environment:
Last Closed: 2017-11-13 08:02:42 UTC
oVirt Team: Node
rule-engine: ovirt-4.1+
rule-engine: blocker+
cshao: testing_ack+


Attachments (Terms of Use)
all log info (deleted)
2017-11-08 10:26 UTC, cshao
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 83757 master MERGED Check if source is a directory in migrate_state 2017-11-08 12:53:19 UTC
oVirt gerrit 83773 ovirt-4.1 MERGED Check if source is a directory in migrate_state 2017-11-08 13:58:24 UTC
oVirt gerrit 83774 ovirt-4.2 MERGED Check if source is a directory in migrate_state 2017-11-08 13:58:31 UTC

Description cshao 2017-11-08 10:26:47 UTC
Created attachment 1349371 [details]
all log info

Description of problem:
Failed to install the ovirt-node-ng 4.1.7 (ovirt-node-ng-installer-ovirt-4.1-2017110715.iso)


There was an error running the kickstart script at line 9.  This is a fatal error and installation will be aborted.  The details of this error are:

2017-11-08 05:13:45,451 [INFO] (MainThread) Trying to create a manageable base from '/'
2017-11-08 05:13:45,920 [INFO] (MainThread) Initial base will be <Base ovirt-node-ng-4.1.7-0.20171107.0 [] />
2017-11-08 05:13:45,921 [INFO] (MainThread) Initial layer will be <Layer ovirt-node-ng-4.1.7-0.20171107.0+1 />
2017-11-08 05:13:45,921 [INFO] (MainThread) Creating an initial base <Base ovirt-node-ng-4.1.7-0.20171107.0 [] /> for <LV 'onn_dhcp-8-106/root' />
2017-11-08 05:13:47,893 [INFO] (MainThread) Creating initial layer <Layer ovirt-node-ng-4.1.7-0.20171107.0+1 /> for initial base
2017-11-08 05:13:47,893 [INFO] (MainThread) Adding a new layer after <Base ovirt-node-ng-4.1.7-0.20171107.0 [] />
2017-11-08 05:13:47,893 [INFO] (MainThread) Adding a new layer after <Base ovirt-node-ng-4.1.7-0.20171107.0 [] />
2017-11-08 05:13:47,893 [INFO] (MainThread) New layer will be: <Layer ovirt-node-ng-4.1.7-0.20171107.0+1 />
2017-11-08 05:13:51,132 [INFO] (migrate_etc) Verifying stream compatability
2017-11-08 05:13:51,141 [INFO] (migrate_etc) Migrating /etc (from <LV 'onn_dhcp-8-106/ovirt-node-ng-4.1.7-0.20171107.0+1' />)
2017-11-08 05:13:51,880 [INFO] (migrate_etc) Migrating /root
2017-11-08 05:13:51,883 [INFO] (fix_systemd_services) Syncing systemd levels
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/imgbased/utils.py", line 1484, in thread_group_handler
    t.join_with_exceptions()
  File "/usr/lib/python2.7/site-packages/imgbased/utils.py", line 1476, in join_with_exceptions
    raise exc[1]
AssertionError
2017-11-08 05:15:20,265 [ERROR] (MainThread) Failed to migrate etc
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/imgbased/plugins/osupdater.py", line 120, in on_new_layer
    thread_group_handler(threads)
  File "/usr/lib/python2.7/site-packages/imgbased/utils.py", line 1487, in thread_group_handler
    sys.exit(1)
SystemExit: 1
Traceback (most recent call last):
  File "/usr/lib64/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib64/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/usr/lib/python2.7/site-packages/imgbased/__main__.py", line 53, in <module>
    CliApplication()
  File "/usr/lib/python2.7/site-packages/imgbased/__init__.py", line 82, in CliApplication
    app.hooks.emit("post-arg-parse", args)
  File "/usr/lib/python2.7/site-packages/imgbased/hooks.py", line 120, in emit
    cb(self.context, *args)
  File "/usr/lib/python2.7/site-packages/imgbased/plugins/core.py", line 173, in post_argparse
    layout.initialize(args.source, args.init_nvr)
  File "/usr/lib/python2.7/site-packages/imgbased/plugins/core.py", line 220, in initialize
    self.app.imgbase.init_layout_from(source, init_nvr)
  File "/usr/lib/python2.7/site-packages/imgbased/imgbase.py", line 292, in init_layout_from
    self.add_layer(initial_base, new_layer)
  File "/usr/lib/python2.7/site-packages/imgbased/imgbase.py", line 191, in add_layer
    self.hooks.emit("new-layer-added", prev_lv, new_lv)
  File "/usr/lib/python2.7/site-packages/imgbased/hooks.py", line 120, in emit
    cb(self.context, *args)
  File "/usr/lib/python2.7/site-packages/imgbased/plugins/osupdater.py", line 123, in on_new_layer
    raise ConfigMigrationError()
imgbased.plugins.osupdater.ConfigMigrationError


Version-Release number of selected component (if applicable):
ovirt-node-ng-installer-ovirt-4.1-2017110715.iso


How reproducible:
100%

Steps to Reproduce:
1. Install ovirt-node-ng-installer-ovirt-4.1-2017110715 via iso, and use the Anaconda GUI mode.
2. Choose auto partitioning, and finish other needed steps.
3.

Actual results:
1. After step2, there are errors popped up at the end of installation as above. 

Expected results:
1. After step2, installation could succeed without errors. 

Additional info:

Comment 1 Ying Cui 2017-11-08 14:03:47 UTC
*** Bug 1511006 has been marked as a duplicate of this bug. ***

Comment 2 Ying Cui 2017-11-09 16:40:27 UTC
Chen(cshao@) tested PASS, then changed the bug to VERIFIED.
ovirt-node-ng-installer-ovirt-4.1-2017110820.iso - Sanity Testing - Pass

Test scenarios with above version:
    1. Install ovirt-node-ng 4.1.7 on UEFI machine - Pass
    2. Install ovirt-node-ng 4.1.7 on FC machine - Pass
    3. Install ovirt-node-ng 4.1.7 on iSCSI machine - Pass
    4. Install ovirt-node-ng 4.1.7 on virtual machine - Pass
    5. Cockpit basic check - Pass

Comment 3 Red Hat Bugzilla Rules Engine 2017-11-13 08:02:06 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.


Note You need to log in before you can comment on or make changes to this bug.