Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510841 - cryptsetup: Fix for unaligned access to hidden truecrypt header caused regression on systems with pagesize > 4KiB [rhel-7.4.z]
Summary: cryptsetup: Fix for unaligned access to hidden truecrypt header caused regres...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cryptsetup
Version: 7.5
Hardware: ppc64le
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Ondrej Kozina
QA Contact: Release Test Team
Marc Muehlfeld
URL:
Whiteboard:
Depends On: 1479857
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-08 10:19 UTC by Oneata Mircea Teodor
Modified: 2018-01-23 18:14 UTC (History)
12 users (show)

Fixed In Version: cryptsetup-1.7.4-3.el7_4.1
Doc Type: Bug Fix
Doc Text:
Due to a bug, the cryptsetup utility previously failed to open certain TrueCrypt images on architectures that use a page size greater than 4 KiB. The problem has been fixed, and cryptsetup now checks that read and write operations for the last part of an image is exactly the requested size instead of a full block. As a result, opening TrueCrypt images works as expected in the mentioned scenario.
Clone Of: 1479857
Environment:
Last Closed: 2017-11-30 16:11:26 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
IBM Linux Technology Center 161109 None None None 2017-11-11 20:15:39 UTC
Red Hat Product Errata RHBA-2017:3330 normal SHIPPED_LIVE cryptsetup bug fix update 2017-11-30 20:20:50 UTC

Description Oneata Mircea Teodor 2017-11-08 10:19:26 UTC
This bug has been copied from bug #1479857 and has been proposed to be backported to 7.4 z-stream (EUS).

Comment 10 errata-xmlrpc 2017-11-30 16:11:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3330


Note You need to log in before you can comment on or make changes to this bug.