Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510811 - v3.7 `oc describe bc` against v3.6 server should display webhook urls with old oapi instead of apis
Summary: v3.7 `oc describe bc` against v3.6 server should display webhook urls with ol...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.7.0
Assignee: David Eads
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-08 09:50 UTC by Xingxing Xia
Modified: 2018-03-05 18:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-05 18:48:39 UTC


Attachments (Terms of Use)

Description Xingxing Xia 2017-11-08 09:50:28 UTC
Description of problem:
v3.7 `oc describe bc` against v3.6 server should display webhook urls with old oapi instead of apis 

Version-Release number of selected component (if applicable):
oc v3.7.0-0.196.0

How reproducible:
Always

Steps to Reproduce:
1. In v3.6 server, create BC
2. Use v3.7 oc to run `oc describe bc` against v3.6 server
$ oc describe bc # the webhook url is ...apis/build.openshift.io/...
...
Webhook Generic:
	URL:		https://MASTER/apis/build.openshift.io/v1/namespaces/xxia-proj/buildconfigs/myrubyapp/webhooks/4a58c26c0d8f5ef0/generic
	AllowEnv:	false
Webhook GitHub:
	URL:	https://MASTER/apis/build.openshift.io/v1/namespaces/xxia-proj/buildconfigs/myrubyapp/webhooks/1e115b0bca152a7d/github
...

3. But the url does not work
$ oc start-build --from-webhook=https://MASTER/apis/build.openshift.io/v1/namespaces/xxia-proj/buildconfigs/myrubyapp/webhooks/4a58c26c0d8f5ef0/generic
error: server rejected our request 500
remote: {"kind":"Status","apiVersion":"v1","metadata":{},"status":"Failure","message":"no kind \"PodProxyOptions\" is registered for version \"build.openshift.io/v1\"","code":500}

Actual results:
3. Above error

Expected results:
2. oc 3.7 should display webhook urls compatible/working in 3.6 server, so that it can be used in step 3

Additional info:

Comment 1 Ben Parees 2017-11-08 18:44:08 UTC
based on this:
error: server rejected our request 500
remote: {"kind":"Status","apiVersion":"v1","metadata":{},"status":"Failure","message":"no kind \"PodProxyOptions\" is registered for version \"build.openshift.io/v1\"","code":500}


i'm pretty sure this is the api grouping issue that David fixed in 3.6.1.

Will let him point this bug to the dupe if he agrees it's the same issue.

Comment 2 Ben Parees 2018-03-05 18:48:39 UTC
at this point we wouldn't backport a fix for this anyway, so closing as won't fix.


Note You need to log in before you can comment on or make changes to this bug.