Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510804 - [APB]Keep spelling style consistent
Summary: [APB]Keep spelling style consistent
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.9.0
Assignee: cchase
QA Contact: Zihan Tang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-08 09:32 UTC by Weihua Meng
Modified: 2018-03-28 14:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the APBs for MariaDB, PostgreSQL, and MySQL were tagged as "databases" instead of "database". This is corrected with the tag "database" matching other services which is now properly shown in search results.
Clone Of:
Environment:
Last Closed: 2018-03-28 14:11:22 UTC


Attachments (Terms of Use)
mariaDB (deleted)
2017-11-08 09:32 UTC, Weihua Meng
no flags Details
postgresql (deleted)
2017-11-08 09:32 UTC, Weihua Meng
no flags Details
apbs (deleted)
2017-11-08 09:33 UTC, Weihua Meng
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0489 None None None 2018-03-28 14:11:45 UTC

Description Weihua Meng 2017-11-08 09:32:08 UTC
Created attachment 1349353 [details]
mariaDB

Description of problem:
both styles are used in OCP, we should keep them consistent.database is preferred.
DATABASE MARIADB
DATABASES MARIADB

DATABASE POSTGRESQL
DATABASES POSTGRESQL

DATABASE MYSQL
DATABASES MYSQL
Version-Release number of selected component (if applicable):
openshift v3.7.0-0.197.0

How reproducible:
Always

Steps to Reproduce:
1. Login Webconsole
2. search those DB

Actual results:
both spelling styles show up
DATABASE MARIADB
DATABASES MARIADB

DATABASE POSTGRESQL
DATABASES POSTGRESQL

DATABASE MYSQL
DATABASES MYSQL

Expected results:
spelling style is consistent.
database is preferred.

Additional info:
screenshots attatched

Comment 1 Weihua Meng 2017-11-08 09:32:49 UTC
Created attachment 1349354 [details]
postgresql

Comment 2 Weihua Meng 2017-11-08 09:33:23 UTC
Created attachment 1349355 [details]
apbs

Comment 5 Zihan Tang 2018-01-03 09:46:04 UTC
Wait for the downstream images ready to verify.

Comment 6 Zihan Tang 2018-01-23 10:10:00 UTC
verified.
image :
registry.access.stage.redhat.com/openshift3/postgresql-apb:v3.9.0-0.20.0.0 registry.access.stage.redhat.com/openshift3/mariadb-apb:v3.9.0-0.20.0.0 registry.access.stage.redhat.com/openshift3/mysql-apb:v3.9.0-0.20.0.0 registry.access.stage.redhat.com/openshift3/mariadb-apb:v3.9.0-0.20.0.0

Comment 9 errata-xmlrpc 2018-03-28 14:11:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0489


Note You need to log in before you can comment on or make changes to this bug.