Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510801 - There is a virt-v2v warning about an unknown VMware controller type when convert a guest from ova file
Summary: There is a virt-v2v warning about an unknown VMware controller type when conv...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs
Version: 7.5
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard: V2V
: 1582699 (view as bug list)
Depends On: 1508874 1551055
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-08 09:24 UTC by mxie@redhat.com
Modified: 2018-10-30 07:47 UTC (History)
7 users (show)

Fixed In Version: libguestfs-1.38.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 07:45:24 UTC


Attachments (Terms of Use)
virt-v2v-ova-unknown-controller.log (deleted)
2017-11-08 09:24 UTC, mxie@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:3021 None None None 2018-10-30 07:47:20 UTC

Description mxie@redhat.com 2017-11-08 09:24:21 UTC
Created attachment 1349342 [details]
virt-v2v-ova-unknown-controller.log

Description of problem:
There is a virt-v2v warning about an unknown VMware controller type when convert a guest from ova file 

Version-Release number of selected component (if applicable):
virt-v2v-1.36.10-2.el7.x86_64
libguestfs-1.36.10-2.el7.x86_64
libvirt-3.9.0-1.el7.x86_64
qemu-kvm-rhev-2.10.0-4.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Convert a guest from ova file which has SATA controller by virt-v2v
.............
     <Item>
        <rasd:Address>0</rasd:Address>
        <rasd:Description>SATA Controller</rasd:Description>
        <rasd:ElementName>SATA controller 0</rasd:ElementName>
        <rasd:InstanceID>3</rasd:InstanceID>
        <rasd:ResourceSubType>vmware.sata.ahci</rasd:ResourceSubType>
        <rasd:ResourceType>20</rasd:ResourceType>
        <vmw:Config ovf:required="false" vmw:key="slotInfo.pciSlotNumber" vmw:value="33"/>
      </Item>
.............

# virt-v2v -i ova esx6.5-rhel7.4-x64-vmware-tools -o rhv -os 10.73.131.93:/home/nfs_export -of raw
[   0.0] Opening the source -i ova esx6.5-rhel7.4-x64-vmware-tools
virt-v2v: warning: making OVA directory public readable to work around 
libvirt bug https://bugzilla.redhat.com/1045069
virt-v2v: warning: ova disk has an unknown VMware controller type (20), 
please report this as a bug supplying the *.ovf file extracted from the ova
[  21.3] Creating an overlay to protect the source from being modified
[  22.0] Initializing the target -o rhv -os 10.73.131.93:/home/nfs_export
[  22.7] Opening the overlay
[  27.3] Inspecting the overlay
[  41.7] Checking for sufficient free disk space in the guest
[  41.7] Estimating space required on target for each disk
[  41.7] Converting Red Hat Enterprise Linux Server 7.4 (Maipo) to run on KVM
virt-v2v: This guest has virtio drivers installed.
[ 119.6] Mapping filesystem data to avoid copying unused and blank areas
[ 119.7] Closing the overlay
[ 121.0] Checking if the guest needs BIOS or UEFI to boot
[ 121.0] Assigning disks to buses
[ 121.0] Copying disk 1/1 to /tmp/v2v.8EAchT/bdf9c90b-e6f0-439c-aa9f-6305fd5fad7e/images/b47711c7-4c6f-4254-ab47-a13e23ff9aac/d23fcfc2-46c5-4177-a064-5a27439f7030 (raw)
    (100.00/100%)
[ 496.2] Creating output metadata
[ 496.3] Finishing off


Actual results:
There is a virt-v2v warning about an unknown VMware controller type

Expected results:
There is no virt-v2v warning about an unknown VMware controller type when convert guest from ova file

Additional info:
1.There is no virt-v2v warning about an unknown VMware controller type when convert same guest from vmware directly by virt-v2v
# virt-v2v -ic vpx://vsphere.local%5cAdministrator@10.73.199.71/data/10.73.196.89/?no_verify=1 esx6.5-rhel7.4-x64-vmware-tools -o rhv -os 10.73.131.93:/home/nfs_export --password-file /tmp/passwd
[   0.0] Opening the source -i libvirt -ic vpx://vsphere.local%5cAdministrator@10.73.199.71/data/10.73.196.89/?no_verify=1 esx6.5-rhel7.4-x64-vmware-tools
[   1.8] Creating an overlay to protect the source from being modified
[   2.6] Initializing the target -o rhv -os 10.73.131.93:/home/nfs_export
[   2.9] Opening the overlay
[  25.4] Inspecting the overlay
[ 157.3] Checking for sufficient free disk space in the guest
[ 157.3] Estimating space required on target for each disk
[ 157.3] Converting Red Hat Enterprise Linux Server 7.4 (Maipo) to run on KVM
virt-v2v: This guest has virtio drivers installed.
[1232.6] Mapping filesystem data to avoid copying unused and blank areas
[1234.1] Closing the overlay
[1234.7] Checking if the guest needs BIOS or UEFI to boot
[1234.7] Assigning disks to buses
[1234.7] Copying disk 1/1 to /tmp/v2v.8vUBAK/bdf9c90b-e6f0-439c-aa9f-6305fd5fad7e/images/fbf1629a-1e51-4926-ab4c-8edbc7dd9e40/c7f91a7e-b977-4294-a7fd-e1c4f40c1260 (raw)
^C  (41.29/100%)

2.I don't know the root reason of this problem, but I think it must be related to SATA controller

Comment 3 Richard W.M. Jones 2017-11-08 11:52:02 UTC
Fixed upstream already in commit b6a9530a303acc5699cde6983dc68aa277715cd7.
Just needs a few backports, I think just these two:

bcb40cb71654a0c525020ddbd49debbfc0d2dbc1
b6a9530a303acc5699cde6983dc68aa277715cd7

Comment 5 Pino Toscano 2018-05-28 11:08:44 UTC
*** Bug 1582699 has been marked as a duplicate of this bug. ***

Comment 6 mxie@redhat.com 2018-06-06 06:09:42 UTC
Reproduce the bug with builds:
virt-v2v-1.36.10-6.el7.x86_64
libguestfs-1.36.10-6.el7.x86_64

Reproduce steps:
1.Convert a ova file which is exported from esx6.5 by virt-v2v
# virt-v2v -i ova esx6.5-rhel7.5-x86_64 -o null
[   0.0] Opening the source -i ova esx6.5-rhel7.5-x86_64
virt-v2v: warning: ova disk has an unknown VMware controller type (20), 
please report this as a bug supplying the *.ovf file extracted from the ova
[  19.0] Creating an overlay to protect the source from being modified
[  19.6] Initializing the target -o null
[  19.6] Opening the overlay
[  52.3] Inspecting the overlay
[  92.7] Checking for sufficient free disk space in the guest
[  92.7] Estimating space required on target for each disk
[  92.7] Converting Red Hat Enterprise Linux Server 7.5 (Maipo) to run on KVM
virt-v2v: This guest has virtio drivers installed.
[ 210.0] Mapping filesystem data to avoid copying unused and blank areas
[ 210.8] Closing the overlay
[ 211.5] Checking if the guest needs BIOS or UEFI to boot
[ 211.5] Assigning disks to buses
[ 211.5] Copying disk 1/1 to /var/tmp/null.f2y4tx/sda (raw)
    (100.00/100%)
[ 252.8] Creating output metadata
[ 252.8] Finishing off

Reproduce result:
   There is a virt-v2v warning about an unknown VMware controller type when convert a guest from ova file which is exported from ESXi6.5



Verify the bug with builds:
virt-v2v-1.38.2-3.el7.x86_64
libguestfs-1.38.2-3.el7.x86_64
libvirt-4.3.0-1.el7.x86_64
qemu-kvm-rhev-2.12.0-3.el7.x86_64

Steps:
1.Convert same ova as reproduce step1 by virt-v2v
# virt-v2v -i ova esx6.5-rhel7.5-x86_64 -o rhv -os 10.66.144.40:/home/nfs_export -on esx6.5-ova -of qcow2
[   0.0] Opening the source -i ova esx6.5-rhel7.5-x86_64
[  13.1] Creating an overlay to protect the source from being modified
[  14.1] Initializing the target -o rhv -os 10.66.144.40:/home/nfs_export
[  14.5] Opening the overlay
[  20.0] Inspecting the overlay
[  87.1] Checking for sufficient free disk space in the guest
[  87.1] Estimating space required on target for each disk
[  87.1] Converting Red Hat Enterprise Linux Server 7.5 (Maipo) to run on KVM
virt-v2v: This guest has virtio drivers installed.
[ 244.3] Mapping filesystem data to avoid copying unused and blank areas
[ 246.3] Closing the overlay
[ 247.9] Checking if the guest needs BIOS or UEFI to boot
[ 247.9] Assigning disks to buses
[ 247.9] Copying disk 1/1 to /tmp/v2v.WB7H5J/ea9cb06f-8bf9-4fc8-a247-478e754d898a/images/dc0ae388-e976-46a2-9549-4c3128c85a75/4f4adf94-2998-48ed-b426-29dd9472ea62 (qcow2)
    (100.00/100%)
[ 366.4] Creating output metadata
[ 366.6] Finishing of

2.Import guest from data domain to export domain after conversion, power on guest and check points of guest are passed

Additional info:
   Convert ESXi6.7 ova to rhv by virt-v2v,There is also no virt-v2v warning about an unknown VMware controller type during conversion and checkpoints of guest are passed

# virt-v2v -i ova esx6.7-rhel7.5-x86_64 -o rhv -os 10.66.144.40:/home/nfs_export -of raw -on esx6.7-ova
[   0.0] Opening the source -i ova esx6.7-rhel7.5-x86_64
[  11.4] Creating an overlay to protect the source from being modified
[  12.0] Initializing the target -o rhv -os 10.66.144.40:/home/nfs_export
[  12.3] Opening the overlay
[  15.7] Inspecting the overlay
[ 305.9] Checking for sufficient free disk space in the guest
[ 305.9] Estimating space required on target for each disk
[ 305.9] Converting Red Hat Enterprise Linux Server 7.5 (Maipo) to run on KVM
virt-v2v: This guest has virtio drivers installed.
[ 502.3] Mapping filesystem data to avoid copying unused and blank areas
[ 504.3] Closing the overlay
[ 505.5] Checking if the guest needs BIOS or UEFI to boot
[ 505.5] Assigning disks to buses
[ 505.5] Copying disk 1/1 to /tmp/v2v.6GhxTV/ea9cb06f-8bf9-4fc8-a247-478e754d898a/images/0f3559bc-c82f-4cfe-a75c-9cb665c04199/ab0c7de8-9917-41ea-91c9-cda23479e4d6 (raw)
    (100.00/100%)
[ 618.3] Creating output metadata
[ 618.5] Finishing off


Verify result:
   There is no virt-v2v warning about an unknown VMware controller type when convert a guest from ova file which is exported from ESXi6.5/ESX6.7, so move the bug from ON_QA to VERIFIED

Comment 8 errata-xmlrpc 2018-10-30 07:45:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:3021


Note You need to log in before you can comment on or make changes to this bug.