Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510798 - [UI] switch buttons are cut-off on edit of Cloud network
Summary: [UI] switch buttons are cut-off on edit of Cloud network
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: GA
: cfme-future
Assignee: Marek Aufart
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-08 09:17 UTC by Mor
Modified: 2018-09-14 13:59 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-13 20:24:46 UTC
Category: Bug
Cloudforms Team: Openstack


Attachments (Terms of Use)
screenshot (deleted)
2017-11-08 09:17 UTC, Mor
no flags Details

Description Mor 2017-11-08 09:17:45 UTC
Created attachment 1349341 [details]
screenshot

Description of problem:
When editing existing OVN network on CFME console, the buttons are cut-off. Tested on Firefox and Chrome.

Version-Release number of selected component (if applicable):
5.9.0.5.20171102023815_209f732 

How reproducible:
100%

Steps to Reproduce:
1. Edit existing OVN network (Networks-->Networks-->choose network-->configuration-->Edit...)

Actual results:
Switch buttons are cut-off.

Expected results:
Should appear normally.

Additional info:
See attached screenshot.

Comment 2 Dan Clarizio 2017-11-09 16:54:25 UTC
Marek, I think if the value is not preset for the switches (which are basically fancy checkboxes), they show strange like in the screenshot.  The value needs to be true or false and not nil.
 . . . Dan

Comment 4 Scott Seago 2018-07-18 19:19:22 UTC
Is this still happening? Does it happen for all networks or just the one in the screenshot? Across multiple CFME servers or just one?

In my dev environment, it's not happening on either firefox or chrome. I've checked on the master branch as well as on the gaprindashvili branch

Comment 5 Mor 2018-07-29 08:23:48 UTC
Omri, can you please check this? 
I'm not testing networking on CFME any more, and we also don't have it enabled on our environment currently.

Comment 6 Sam Lucidi 2018-09-13 20:24:46 UTC
Since Scott couldn't reproduce the bug, and we haven't heard any more from QE, going to close this as WORKSFORME. If this issue reappears, please reopen.


Note You need to log in before you can comment on or make changes to this bug.