Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510797 - OPS UI doesn't show linked VMs in ansible service
Summary: OPS UI doesn't show linked VMs in ansible service
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: All
OS: All
high
medium
Target Milestone: GA
: 5.10.0
Assignee: Martin Povolny
QA Contact: Kedar Kulkarni
URL:
Whiteboard: ansible:service:ui
: 1512636 (view as bug list)
Depends On:
Blocks: 1513248
TreeView+ depends on / blocked
 
Reported: 2017-11-08 09:14 UTC by Dmitry Misharov
Modified: 2018-06-21 20:27 UTC (History)
6 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1513248 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:27:41 UTC
Category: ---
Cloudforms Team: ---
kkulkarn: automate_bug+


Attachments (Terms of Use)

Description Dmitry Misharov 2017-11-08 09:14:35 UTC
Description of problem:


Version-Release number of selected component (if applicable):
5.9.0.5.20171102023815_209f732

How reproducible:
Always

Steps to Reproduce:
1. Enable Embedded Ansible role.
2. Wait until it will be enabled.
3. Navigate to Automate/Ansible.
4. Add ansible repository https://github.com/mkanoor/playbook.
5. Navigate to Services->Catalogs.
6. Expand "Catalog Items" accordion.
7. Create "Ansible Playbook" Catalog Item.
8. Pick "add_single_vm_to_service.yml" playbook.
9. Navigate to Control->Explorer.
10. Expand Actions accordion.
11. Click Configuration->Add a new Action.
12. In action type choose "Run Ansible Playbook".
13. In Playbook Catalog Item choose just created catalog item.
14. In inventory choose "Target machine" or provide a specific host.
15. Assign this action to some event in a host or vm control policy.
16. Assign policy profile which contains that policy to some host or vm.
17. Trigger the event which assigned to the policy. 
18. Wait until the service will be provisioned.
19. Navigate tot Services/My Services.
20. Open details of the provisioned service, open "Provisioning" tab.

Actual results:
There is no linked vm. 

Expected results:
Details screen of a service should show linked VMs.

Comment 4 Harpreet Kataria 2017-11-13 21:15:55 UTC
*** Bug 1512636 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.