Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510773 - rpm verification failed for dbus package
Summary: rpm verification failed for dbus package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dbus
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: David King
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-08 08:27 UTC by Tomas Pelka
Modified: 2018-04-10 12:54 UTC (History)
2 users (show)

Fixed In Version: dbus-1.10.24-7.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 12:52:20 UTC


Attachments (Terms of Use)
fix the mode of /run/dbus (deleted)
2018-02-15 13:33 UTC, David King
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0765 None None None 2018-04-10 12:54:03 UTC

Description Tomas Pelka 2017-11-08 08:27:11 UTC
Description of problem:
rpm verification failed for dbus package

Version-Release number of selected component (if applicable):
dbus-1.10.24-3.el7

How reproducible:
100%

Steps to Reproduce:
1. have new dbus rpms installed 
2. rpm -V dbus
3.

Actual results:
# rpm -V dbus
.M.......  g /run/dbus
..?......    /usr/libexec/dbus-1/dbus-daemon-launch-helper

If I'm not mistaken the first line means "verify error on file not present in alternative arch"

Expected results:
no error

Additional info:
It is not happening with dbus-1.6.12-17.el7 so adding regression keyword

Comment 2 David King 2018-02-15 13:33:32 UTC
Created attachment 1396493 [details]
fix the mode of /run/dbus

The /rub/dbus directory is marked with a %ghost directive, but the 'M' stands for the mode (permission  and/or file type) differing between the rpm and the system. On my system, the real /run/dbus is 755 and the RPM has no permission bits set. The attached patch fixes this.

Comment 7 errata-xmlrpc 2018-04-10 12:52:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0765


Note You need to log in before you can comment on or make changes to this bug.