Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510770 - Execution ansible playbook method fails
Summary: Execution ansible playbook method fails
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.9.0
Hardware: All
OS: All
high
medium
Target Milestone: Beta 1
: 5.9.0
Assignee: mkanoor
QA Contact: Dmitry Misharov
URL:
Whiteboard: automate:ansible
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-08 08:14 UTC by Dmitry Misharov
Modified: 2017-12-05 15:13 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-09 22:32:40 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)
Job status (deleted)
2017-11-08 08:14 UTC, Dmitry Misharov
no flags Details

Description Dmitry Misharov 2017-11-08 08:14:17 UTC
Created attachment 1349303 [details]
Job status

Description of problem:
If ansible playbook method has more than one input parameters than execution will fail with error: "undefined method 'each_pair'".

Version-Release number of selected component (if applicable):
5.9.0.5.20171102023815_209f732

How reproducible:
Always

Steps to Reproduce:
1. Enable Embedded Ansible Role.
2. Add some ansible playbooks repository.
3. Navigate to Automate/Explorer.
4. Create some domain, namespace, class and instance.
5. Create a ansible playbook method. Fill required fields. Add more than one input parameters.
6. Navigate to Automate/Simulation.
7. Call the instance in the simulation.

Actual results:
Execution fails with "undefined method 'each_pair'" error in the job status.

Expected results:
Execution should be executed successfully.

Additional info:

Comment 2 mkanoor 2017-11-09 17:48:51 UTC
Worked with QE and couldn't reproduce it.

Comment 3 Dave Johnson 2017-11-09 22:32:40 UTC
Moving to closed per comment 2, Dima, please reopen if you jit this again.

Comment 4 Dmitry Misharov 2017-11-10 08:19:26 UTC
I can't reproduce it on 5.9.0.7.


Note You need to log in before you can comment on or make changes to this bug.