Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510762 - neovim-0.2.1 version bump
Summary: neovim-0.2.1 version bump
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: neovim
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Schneider
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1510789
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-08 07:39 UTC by Anton Kochkov
Modified: 2017-12-19 19:47 UTC (History)
3 users (show)

Fixed In Version: neovim-0.2.1-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-19 19:47:51 UTC


Attachments (Terms of Use)

Description Anton Kochkov 2017-11-08 07:39:52 UTC
Quite a substantial release of Neovim, despite the minor version change. 

https://github.com/neovim/neovim/releases/tag/v0.2.1

Changelog:

FEATURES:
0e873a3 Lua(Jit) built-in #4411
5b32bce Windows: `:terminal` #7007
7b0ceb3 UI/API: externalize cmdline #7173
b67f58b UI/API: externalize wildmenu #7454
b23aa1c UI: 'winhighlight' #6597
17531ed UI: command-line coloring (`:help input()-highlight`) #6364
244a1f9 API: execute lua directly from the remote api #6704
45626de API: `get_keymap()` #6236
db99982 API: `nvim_get_hl_by_name()`, `nvim_get_hl_by_id()` #7082
dc68538 menu_get() function #6322
9db42d4 :cquit : take an error code argument #7336
9cc185d job-control: serverstart(): support ipv6 #6680
1b7a9bf job-control: sockopen() #6594
6efe84a clipboard: fallback to tmux clipboard #6894
6016ac2 clipboard: customize clipboard with `g:clipboard` #6030
3a86dd5 ruby: override ruby host via `g:ruby_host_prog` #6841
16cce1a debug: $NVIM_LOG_FILE #6827
0cba3da `:checkhealth` built-in, validates $VIMRUNTIME #7399

FIXES:
105d680 TUI: more terminals, improve scroll/resize #6816
cb912a3 :terminal : handle F1-F12, other keys #7241
619838f inccommand: improve performance #6949
04b3c32 inccommand: Fix matches for zero-width #7487
60b1e8a inccommand: multiline, other fixes #7315
f1f7f3b inccommand: Ignore leading modifiers in the command #6967
1551f71 inccommand: fix 'gdefault' lockup #7262
6338199 API: bufhl: support creating new groups #7414
541dde3 API: allow K_EVENT during operator-pending
8c732f7 terminal: adjust for 'number' #7440
5bec946 UI: preserve wildmenu during jobs/events #7110
c349083 UI: disable 'lazyredraw' during ui_refresh. #6259
51808a2 send FocusGained/FocusLost event instead of pseudokey #7221
133f8bc shada: preserve unnamed register on restart #4700
1b70a1d shada: avoid assertion on corrupt shada file #6958
9f534f3 mksession: Restore tab-local working directory #6859
de1084f fix buf_write() crash #7140
7f76986 syntax: register 'Normal' highlight group #6973
6e7a8c3 RPC: close channel if stream was closed #7081
85f3084 clipboard: disallow recursion; show hint only once #7203
8d1ccb6 clipboard: performance, avoid weird edge-cases #7193
01487d4 'titleold' #7358
01e53a5 Windows: better path-handling, separator (slash) hygiene #7349
0f2873c Windows: multibyte startup arguments #7060

CHANGES:
9ff0cc7 :terminal : start in normal-mode #6808
032b088 lower priority of 'cursorcolumn', 'colorcolumn' #7364
2a3bcd1 RPC: Don't delay notifications when request is pending #6544
023f67c :terminal : Do not change 'number', 'relativenumber' #6796
1ef2d76 socket.c: Disable Nagle's algorithm on TCP sockets #6915
6720fe2 help: `K` tries Vim help instead of manpage #3104
7068370 help, man.vim: change "outline" map to `gO` #7405

Comment 1 Andreas Schneider 2017-11-08 12:54:37 UTC

*** This bug has been marked as a duplicate of bug 1510899 ***

Comment 2 Fedora Update System 2017-12-08 17:29:51 UTC
neovim-0.2.1-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4c6a10cec7

Comment 3 Fedora Update System 2017-12-10 00:33:43 UTC
lua-mpack-1.0.7-1.fc27, neovim-0.2.1-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4c6a10cec7

Comment 4 Fedora Update System 2017-12-19 19:47:51 UTC
lua-mpack-1.0.7-1.fc27, neovim-0.2.1-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.