Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510727 - The subscription-manager gui could not be launched after delete the consumer info from the server side
Summary: The subscription-manager gui could not be launched after delete the consumer ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.5
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: Red Hat subscription-manager QE Team
URL:
Whiteboard:
: 1511804 (view as bug list)
Depends On:
Blocks: 1444512
TreeView+ depends on / blocked
 
Reported: 2017-11-08 05:27 UTC by Wei Liu
Modified: 2018-04-10 09:53 UTC (History)
8 users (show)

Fixed In Version: subscription-manager-1.20.9-1
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-04-10 09:52:44 UTC


Attachments (Terms of Use)
the rhsm log (deleted)
2017-11-08 05:27 UTC, Wei Liu
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 09:53:21 UTC
Github candlepin subscription-manager pull 1745 None None None 2017-12-13 08:57:33 UTC

Description Wei Liu 2017-11-08 05:27:38 UTC
Created attachment 1349252 [details]
the rhsm log

Description of problem:
The subscription-manager gui could not be launched after delete the consumer info from the  server side

Version-Release number of selected component (if applicable):
[root@cloud-qe-16-vm-01 rhsm]# rpm -qa | egrep "subscription|rhsm"
subscription-manager-gui-1.20.5-1.el7.x86_64
subscription-manager-rhsm-certificates-1.20.5-1.el7.x86_64
subscription-manager-rhsm-1.20.5-1.el7.x86_64
subscription-manager-1.20.5-1.el7.x86_64
subscription-manager-initial-setup-addon-1.20.5-1.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.Install build RHEL-7.5-20171107.1

2.Register the system and attach subscription then check the consumer info 
[root@cloud-qe-16-vm-01 ~]# subscription-manager identity
system identity: 87e682c3-93e2-40ca-ad79-5e1025276a53
name: cloud-qe-16-vm-01.idmqe.lab.eng.bos.redhat.com
org name: 11358451
org ID: 11358451

3.Try to open the subscription-manager gui by command line and it be launched successfully
#subscription-manager-gui

4.Delete the consumer info from the server side
[root@cloud-qe-16-vm-01 ~]# curl -k -u username:****** --request DELETE https://subscription.rhsm.stage.redhat.com:443/subscription/consumers/87e682c3-93e2-40ca-ad79-5e1025276a53

5.Try to launch the subscription-manager gui again as step 3. Failed to launch and an output message was shown
#subscription-manager-gui
Unit 87e682c3-93e2-40ca-ad79-5e1025276a53 has been deleted


Actual results:
After step 5. the subscription-manager gui was not launched successfully

Expected results:
The subscription-manager gui was not launched successfully after delete the consumer info from the server side

Additional info:

Comment 3 Chris Snyder 2017-11-16 15:28:51 UTC
*** Bug 1511804 has been marked as a duplicate of this bug. ***

Comment 4 Wei Liu 2017-11-17 02:38:03 UTC
Hi Chris

Today I did the same operations on build RHEL-7.4-20170711.0

[root@dhcp-129-165 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.0.43-1
subscription management rules: 5.26
subscription-manager: 1.19.21-1.el7
python-rhsm: 1.19.9-1.el7

[root@dhcp-129-165 ~]# subscription-manager register
Registering to: subscription.rhsm.stage.redhat.com:443/subscription
Username: rnew_test
Password: 
The system has been registered with ID: e944756a-0450-4396-bd29-7b144496ea9d 

[root@dhcp-129-165 ~]# subscription-manager identity
system identity: e944756a-0450-4396-bd29-7b144496ea9d
name: dhcp-129-165.nay.redhat.com
org name: 11367791
org ID: 11367791

[root@dhcp-129-165 ~]# curl -k -u rnew_test:redhat --request DELETE https://subscription.rhsm.stage.redhat.com:443/subscription/consumers/e944756a-0450-4396-bd29-7b144496ea9d

[root@dhcp-129-165 ~]# subscription-manager-gui

Finally the subscription-manager gui was launched successfully.So I think this is a regression.

Thank you!
weiliu

Comment 7 Wei Liu 2017-12-19 03:36:05 UTC
Verifying version:
[root@bkr-hv03-guest35 ~]# rpm -qa | egrep "rhsm|subscription"
subscription-manager-initial-setup-addon-1.20.9-1.el7.x86_64
subscription-manager-rhsm-1.20.9-1.el7.x86_64
subscription-manager-gui-1.20.9-1.el7.x86_64
subscription-manager-rhsm-certificates-1.20.9-1.el7.x86_64
subscription-manager-1.20.9-1.el7.x86_64

Verification:
1.Register the system to server
[root@bkr-hv03-guest35 ~]# subscription-manager register
Registering to: subscription.rhsm.stage.redhat.com:443/subscription
Username: rnew_test
Password: 
The system has been registered with ID: f495a8b6-72ee-4625-8e77-b73b7a1672ac
The registered system name is: bkr-hv03-guest35.dsal.lab.eng.bos.redhat.com

2.Try to open the subscription-manager gui by command line and it be launched successfully
#subscription-manager-gui

3.Delete the consumer info from the server side
[root@bkr-hv03-guest35 ~]# curl -k -u username:****** --request DELETE https://subscription.rhsm.stage.redhat.com:443/subscription/consumers/f495a8b6-72ee-4625-8e77-b73b7a1672ac

4.Try to launch the subscription-manager gui again.The gui was launched successfully and no error message was shown.

As the subscription-manager gui was launched successfully after deleting the consumer info from the server side.So this issue is verified and move the status to "verified".

Comment 8 Kevin Howell 2018-01-24 16:08:11 UTC
*** Bug 1510759 has been marked as a duplicate of this bug. ***

Comment 11 errata-xmlrpc 2018-04-10 09:52:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681


Note You need to log in before you can comment on or make changes to this bug.