Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510685 - Python modules not found when multiple versions of Python installed
Summary: Python modules not found when multiple versions of Python installed
Keywords:
Status: NEW
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Kotresh HR
QA Contact: Rahul Hinduja
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-08 01:07 UTC by Axel Ulrich
Modified: 2018-02-06 08:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Axel Ulrich 2017-11-08 01:07:27 UTC
Description of problem:
On a system with Python2.7 and Python2.6, with Python2.7 being the default, site-packages from GlusterFS and Python dependency prettytable are installed into Python2.6 when install via rpm packages.  When running gluster commands that depend on those they are not found.

Version-Release number of selected component (if applicable):
GlusterFS 3.12

Example:
$ sudo gluster-mountbroker setup /var/mountbroker-root geogroup
this command comes back with an error:
Traceback (most recent call last):
  File "/usr/sbin/gluster-mountbroker", line 5, in <module>
    from gluster.cliutils import (execute, Cmd, node_output_ok,
ImportError: No module named gluster.cliutils

Fix without changing Python default to 2.6:
$ sudo cp -r /usr/lib/python2.6/site-packages/* /usr/lib/python2.7/site-packages/
$ sudo yum install python27-prettytable


Because the gluster documentation states support for Python2.6 'or higher', wouldn't a better approach of the install be to install packages/dependencies into all Python2.6 or higher versions on the system at the time of install? I wonder actually what happens on a system with only Python2.7 at the time of install.

Comment 2 Aravinda VK 2018-02-06 08:12:16 UTC
Moving this issue to upstream


Note You need to log in before you can comment on or make changes to this bug.