Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510654 - kdump.service fails to start when crashkernel=auto with "No memory reserved for crash kernel"
Summary: kdump.service fails to start when crashkernel=auto with "No memory reserved f...
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kexec-tools
Version: 7.5-Alt
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: kdump team
QA Contact: Kernel General QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-07 22:41 UTC by Afom T. Michael
Modified: 2017-11-09 07:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-09 07:12:37 UTC


Attachments (Terms of Use)

Description Afom T. Michael 2017-11-07 22:41:16 UTC
Description of problem:
kdump service fails to start when set with "crashkernel=auto" running 4.14.0-0.rc7.1.el7a.ppc64le. 

Version-Release number of selected component (if applicable):
$ cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.5 Beta (Maipo)
$ uname -rm
4.14.0-0.rc7.2.el7a.x86_64 x86_64
$ rpm -q kexec-tools
kexec-tools-2.0.15-4.el7.x86_64
$

How reproducible:
Always

Steps to Reproduce:
1. Install latest such as RHEL-ALT-7.5-20171106.1
2. Install kexec-tools and add crashkernel=auto in grub (as described on https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/kernel_crash_dump_guide/sect-kdump-config-cli)
3. reboot & check kdump status (systemctl status kdump -l)

Actual results:
kdump service doesn't start with "...kdumpctl[2041]: No memory reserved for crash kernel..."

$ free -m
              total        used        free      shared  buff/cache   available
Mem:          32228         363       31647           9         217       31450
Swap:         16127           0       16127
$ cat /proc/cmdline 
BOOT_IMAGE=/vmlinuz-4.14.0-0.rc7.2.el7a.x86_64 root=/dev/mapper/rhelaa_rdma--dev--05-root ro console=tty0 rd_NO_PLYMOUTH crashkernel=auto rd.lvm.lv=rhelaa_rdma-dev-05/root rd.lvm.lv=rhelaa_rdma-dev-05/swap console=ttyS1,115200
$ systemctl is-enabled kdump
enabled
$ systemctl is-active kdump
failed
$ systemctl status kdump -l
● kdump.service - Crash recovery kernel arming
   Loaded: loaded (/usr/lib/systemd/system/kdump.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2017-11-07 21:09:08 EST; 47min ago
  Process: 970 ExecStart=/usr/bin/kdumpctl start (code=exited, status=1/FAILURE)
 Main PID: 970 (code=exited, status=1/FAILURE)

Nov 07 21:09:08 localhost.localdomain systemd[1]: Starting Crash recovery kernel arming...
Nov 07 21:09:08 localhost.localdomain kdumpctl[970]: No memory reserved for crash kernel
Nov 07 21:09:08 localhost.localdomain kdumpctl[970]: Starting kdump: [FAILED]
Nov 07 21:09:08 localhost.localdomain systemd[1]: kdump.service: main process exited, code=exited, status=1/FAILURE
Nov 07 21:09:08 localhost.localdomain systemd[1]: Failed to start Crash recovery kernel arming.
Nov 07 21:09:08 localhost.localdomain systemd[1]: Unit kdump.service entered failed state.
Nov 07 21:09:08 localhost.localdomain systemd[1]: kdump.service failed.
$ systemctl start kdump
Job for kdump.service failed because the control process exited with error code. See "systemctl status kdump.service" and "journalctl -xe" for details.
$ 

Expected results:
For kdump to start & run when set with crashkernel=auto.

Additional info:
Seen on x86_64 & ppc64le

Comment 3 Afom T. Michael 2017-11-07 22:46:09 UTC
The service starts/runs when crashkernel is set to a numeric value (memory size), Eg. 128M

Comment 5 Dave Young 2017-11-09 07:12:37 UTC

*** This bug has been marked as a duplicate of bug 1431982 ***


Note You need to log in before you can comment on or make changes to this bug.