Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510639 - host registration fails during provisioning if using a limited host collection
Summary: host registration fails during provisioning if using a limited host collection
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Kedar Bidarkar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-07 21:43 UTC by Og Maciel
Modified: 2019-04-01 20:27 UTC (History)
5 users (show)

Fixed In Version: rubygem-katello-3.4.5.43-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-21 16:54:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 21961 None None None 2017-12-13 15:09:36 UTC

Description Og Maciel 2017-11-07 21:43:58 UTC
Description of problem:


The problem boils down to this: if you're provisioning a host (libvirt in my case) using a host group/activationkey/host collection where the host collection is set to a limit, the registration process fails with the error:

  Host collection 'RHEL 7' exceeds maximum usage limit of '5'

If you change the host collection to unlimited, then registration proceeds without a glitch

 
Version-Release number of selected component (if applicable):

* satellite-6.3.0-21.0.beta.el7sat.noarch

How reproducible:


Steps to Reproduce:
1. Sync content and add it to a content view
2. Publish/promote content view
3. Create activation key, associate it to the content view AND set a limit of 5 hosts
4. Create a host collection is set a limit of 5 hosts
5. Associate the host collection to the activation key
6. Provision a new host using the host group created earlier


Actual results:

The host will provision but it will not be registered


Expected results:


Additional info:

See logs further down

Comment 3 Og Maciel 2017-11-07 22:08:29 UTC
Even if I set the host collection to unlimited host limit and manually attempt to register an existing host, I still get the same error:

# subscription-manager register --org="dc8079af-8e04-4d63-897c-2ecbf89aad78" --activationkey="ak-rhel-70"
Host collection 'RHEL 7' exceeds maximum usage limit of '5'

For new registrations, this works fine.

Comment 4 Brad Buckingham 2017-12-13 15:09:34 UTC
Created redmine issue http://projects.theforeman.org/issues/21961 from this bug

Comment 5 pm-sat@redhat.com 2017-12-14 17:14:46 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/21961 has been resolved.

Comment 8 Kedar Bidarkar 2018-01-30 06:36:28 UTC
I have a setup ready with snap31+, will pick this up and verify this.

Comment 11 Kedar Bidarkar 2018-01-30 08:52:37 UTC
VERIFIED with sat63.0-snap32.0

Comment 12 pm-sat@redhat.com 2018-02-21 16:54:17 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA.
> 
> For information on the advisory, and where to find the updated files, follow the link below.
> 
> If the solution does not work for you, open a new bug report.
> 
> https://access.redhat.com/errata/RHSA-2018:0336


Note You need to log in before you can comment on or make changes to this bug.