Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510589 - wsgi:pulp segfaults resulting in core dump of httpd
Summary: wsgi:pulp segfaults resulting in core dump of httpd
Keywords:
Status: CLOSED DUPLICATE of bug 1516481
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-07 18:14 UTC by Dylan Gross
Modified: 2019-04-01 20:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-30 21:46:54 UTC


Attachments (Terms of Use)

Description Dylan Gross 2017-11-07 18:14:33 UTC
Description of problem:

   During nightly pulp activity, httpd segfaults and coredumps.




Version-Release number of selected component (if applicable):

   Red Hat Satellite 6.2.12
   httpd-2.4.6-67.el7_4.2

How reproducible:   Unknown

Actual results:

   Segmentation fault on httpd

Expected results:

   No segmentation fault

Additional info:

Comment 3 pulp-infra@redhat.com 2017-11-13 21:04:50 UTC
The Pulp upstream bug status is at NEW. Updating the external tracker on this bug.

Comment 4 pulp-infra@redhat.com 2017-11-13 21:04:53 UTC
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.

Comment 5 Dylan Gross 2017-11-14 23:06:13 UTC
From the 11/02 coredump...

[New LWP 11566]
[New LWP 11568]
[New LWP 13421]
[New LWP 11131]
[New LWP 11567]
[New LWP 11569]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Core was generated by `(wsgi:pulp)     -DFOREGROUND'.
Program terminated with signal 11, Segmentation fault.
#0  _PyTrash_thread_destroy_chain () at /usr/src/debug/Python-2.7.5/Objects/object.c:2510
2510	        destructor dealloc = Py_TYPE(op)->tp_dealloc;


(gdb) info threads
  Id   Target Id         Frame 
  6    Thread 0x7f09f2ffd700 (LWP 11569) 0x00007f0a1f99590d in do_fcntl (arg=<optimized out>, cmd=7, fd=22) at ../sysdeps/unix/sysv/linux/fcntl.c:39
  5    Thread 0x7f09f3fff700 (LWP 11567) 0x00007f0a1f4af7a3 in select () at ../sysdeps/unix/syscall-template.S:81
  4    Thread 0x7f0a20eaf880 (LWP 11131) 0x00007f0a1f994a0b in futex_abstimed_wait (cancel=true, private=<optimized out>, abstime=0x0, expected=0, futex=0x55730f57c570)
    at ../nptl/sysdeps/unix/sysv/linux/sem_waitcommon.c:43
  3    Thread 0x7f09e6ff5700 (LWP 13421) 0x00007f0a1f47f1ad in nanosleep () at ../sysdeps/unix/syscall-template.S:81
  2    Thread 0x7f09f37fe700 (LWP 11568) 0x00007f0a1f4af7a3 in select () at ../sysdeps/unix/syscall-template.S:81
* 1    Thread 0x7f09f8f90700 (LWP 11566) _PyTrash_thread_destroy_chain () at /usr/src/debug/Python-2.7.5/Objects/object.c:2510


(gdb) frame 0
#0  _PyTrash_thread_destroy_chain () at /usr/src/debug/Python-2.7.5/Objects/object.c:2510
2510	        destructor dealloc = Py_TYPE(op)->tp_dealloc;


(gdb) list
2505	_PyTrash_thread_destroy_chain(void)
2506	{
2507	    PyThreadState *tstate = PyThreadState_GET();
2508	    while (tstate->trash_delete_later) {
2509	        PyObject *op = tstate->trash_delete_later;
2510	        destructor dealloc = Py_TYPE(op)->tp_dealloc;   <<< ?
2511	
2512	        tstate->trash_delete_later =
2513	            (PyObject*) _Py_AS_GC(op)->gc.gc_prev;
2514	

(gdb) print op
$1 = <unknown at remote 0x1d0>

Comment 6 pulp-infra@redhat.com 2017-11-17 16:02:12 UTC
The Pulp upstream bug priority is at High. Updating the external tracker on this bug.

Comment 7 Dylan Gross 2017-11-30 21:46:54 UTC

*** This bug has been marked as a duplicate of bug 1516481 ***


Note You need to log in before you can comment on or make changes to this bug.