Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510524 - dropdown menu for refresh interval in dashboard is not visible
Summary: dropdown menu for refresh interval in dashboard is not visible
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine-dashboard
Classification: oVirt
Component: General
Version: 1.2.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ovirt-4.2.0
: ---
Assignee: Scott Dickerson
QA Contact: Pavel Novotny
URL:
Whiteboard:
: 1517082 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-07 15:29 UTC by Lucie Leistnerova
Modified: 2017-12-20 10:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
: 1512574 (view as bug list)
Environment:
Last Closed: 2017-12-20 10:52:11 UTC
oVirt Team: UX
rule-engine: ovirt-4.2+
pnovotny: testing_plan_complete-


Attachments (Terms of Use)
refresh dropdown menu (deleted)
2017-11-07 15:29 UTC, Lucie Leistnerova
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 83880 master MERGED Hide tooltip on refresh button when it's clicked or expanded 2017-11-10 11:44:48 UTC
oVirt gerrit 84032 ovirt-engine-dashboard-1.1 MERGED Hide tooltip on refresh button when it's clicked or expanded 2017-11-13 16:48:59 UTC

Description Lucie Leistnerova 2017-11-07 15:29:49 UTC
Created attachment 1349021 [details]
refresh dropdown menu

Description of problem:
The dropdown menu for refresh interval is not visible. The help is overlaping it.

Version-Release number of selected component (if applicable):
ovirt-engine-dashboard-1.2.0-0.7.20171103git5c20c87.el7.centos.noarch

How reproducible: always


Steps to Reproduce:
1. click on dropdown menu next to refresh button in top left corner of dashboard


Actual results: help is displayed, dropdown menu is not visible, see attachment


Expected results: help hides after clicking on the dropdown menu

Comment 1 Greg Sheremeta 2017-11-07 17:30:39 UTC
"Expected results: help hides after clicking on the dropdown menu"

In webadmin (GWT), we have a global click handler that closes all tooltips onclick. We may need a similar thing in the dashboard app.

Comment 3 Greg Sheremeta 2017-11-15 00:20:43 UTC
The dropdown menu has been removed since it only had a single option that said 'manual' -- so please QA that the refresh button + tooltip works as expected, looks good, etc.

Comment 4 Pavel Novotny 2017-11-20 18:40:01 UTC
Verified in 
ovirt-engine-4.2.0-0.0.master.20171119135709.git6d448d3.el7.centos.noarch
ovirt-engine-dashboard-1.2.0-0.8.20171114git2a2317c.el7.centos.noarch

The dropdown menu has been removed and the tooltip for the refresh button works and looks as expected.

Comment 5 Sandro Bonazzola 2017-11-24 14:22:57 UTC
Greg, looks like this bug is referenced in ovirt-engine-dashboard-1.1.8-1 git log.
Can you please cross check this bug is correctly targeted to 4.2 and shouldn't be targeted 4.1.8?

Comment 6 Sandro Bonazzola 2017-11-24 14:23:46 UTC
(In reply to Sandro Bonazzola from comment #5)
> Greg, looks like this bug is referenced in ovirt-engine-dashboard-1.1.8-1
> git log.
> Can you please cross check this bug is correctly targeted to 4.2 and
> shouldn't be targeted 4.1.8?

nevermind, I see this has been cloned to 4.1.8

Comment 7 Greg Sheremeta 2017-11-27 20:20:55 UTC
*** Bug 1517082 has been marked as a duplicate of this bug. ***

Comment 8 Sandro Bonazzola 2017-12-20 10:52:11 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.