Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1510498 - cannot add rhv41 provider in 5.9.0.5. credentials validation cannot be passed
Summary: cannot add rhv41 provider in 5.9.0.5. credentials validation cannot be passed
Keywords:
Status: CLOSED DUPLICATE of bug 1509432
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: GA
: cfme-future
Assignee: Bronagh Sorota
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-07 15:01 UTC by Ievgen Zapolskyi
Modified: 2017-11-07 15:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-07 15:16:28 UTC
Category: Bug
Cloudforms Team: RHEVM


Attachments (Terms of Use)
cfme logs (deleted)
2017-11-07 15:03 UTC, Ievgen Zapolskyi
no flags Details

Description Ievgen Zapolskyi 2017-11-07 15:01:37 UTC
Description of problem:
CFME produces error "Credential validation was not successful: HTTP response code is 302. The response content type '' isn't JSON." on attempt to validate credentials for rhv41 provider. The provider is added correctly in 5.9.0.4 and latest 5.8.

Version-Release number of selected component (if applicable):
5.9.0.5

How reproducible:
100%

Steps to Reproduce:
1. Try to add rhv41 provider in cfme


Actual results:
error message on attempt to validate credentials.
logs contain appropriate exception

Expected results:
correct adding rhv41 provider

Additional info:
Exception:

[----] I, [2017-11-07T09:56:48.516762 #12387:533130]  INFO -- : MIQ(MiqQueue#deliver) Message id: [370], Delivering...
[----] E, [2017-11-07T09:56:48.520196 #12387:533130] ERROR -- : MIQ(MiqQueue#deliver) Message id: [370], Error: [HTTP response code is 302. The response content type '' isn't JSON.]
[----] E, [2017-11-07T09:56:48.520362 #12387:533130] ERROR -- : [OvirtSDK4::Error]: HTTP response code is 302. The response content type '' isn't JSON.  Method:[block in method_missing]
[----] E, [2017-11-07T09:56:48.520426 #12387:533130] ERROR -- : /opt/rh/rh-ruby23/root/usr/share/gems/gems/ovirt-engine-sdk-4.1.9/lib/ovirtsdk4/connection.rb:509:in `raise_error'
/opt/rh/rh-ruby23/root/usr/share/gems/gems/ovirt-engine-sdk-4.1.9/lib/ovirtsdk4/connection.rb:553:in `check_content_type'
/opt/rh/rh-ruby23/root/usr/share/gems/gems/ovirt-engine-sdk-4.1.9/lib/ovirtsdk4/connection.rb:447:in `check_json_content_type'
/opt/rh/rh-ruby23/root/usr/share/gems/gems/ovirt-engine-sdk-4.1.9/lib/ovirtsdk4/connection.rb:285:in `get_sso_response'
/opt/rh/rh-ruby23/root/usr/share/gems/gems/ovirt-engine-sdk-4.1.9/lib/ovirtsdk4/connection.rb:223:in `create_access_token'
/opt/rh/rh-ruby23/root/usr/share/gems/gems/ovirt-engine-sdk-4.1.9/lib/ovirtsdk4/connection.rb:587:in `internal_send'
/opt/rh/rh-ruby23/root/usr/share/gems/gems/ovirt-engine-sdk-4.1.9/lib/ovirtsdk4/connection.rb:198:in `block in send'
/opt/rh/rh-ruby23/root/usr/share/gems/gems/ovirt-engine-sdk-4.1.9/lib/ovirtsdk4/connection.rb:198:in `synchronize'
/opt/rh/rh-ruby23/root/usr/share/gems/gems/ovirt-engine-sdk-4.1.9/lib/ovirtsdk4/connection.rb:198:in `send'
/opt/rh/rh-ruby23/root/usr/share/gems/gems/ovirt-engine-sdk-4.1.9/lib/ovirtsdk4/service.rb:148:in `internal_get'
/opt/rh/rh-ruby23/root/usr/share/gems/gems/ovirt-engine-sdk-4.1.9/lib/ovirtsdk4/services.rb:22474:in `get'
/opt/rh/rh-ruby23/root/usr/share/gems/gems/ovirt-engine-sdk-4.1.9/lib/ovirtsdk4/connection.rb:362:in `test'
/opt/rh/cfme-gemset/bundler/gems/manageiq-providers-ovirt-3c9a90463c98/app/models/manageiq/providers/redhat/infra_manager/api_integration.rb:244:in `raw_connect'
/var/www/miq/vmdb/app/models/miq_queue.rb:449:in `block in dispatch_method'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:91:in `block in timeout'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:33:in `block in catch'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:33:in `catch'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:33:in `catch'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:106:in `timeout'
/var/www/miq/vmdb/app/models/miq_queue.rb:448:in `dispatch_method'
/var/www/miq/vmdb/app/models/miq_queue.rb:425:in `block in deliver'
/var/www/miq/vmdb/app/models/user.rb:252:in `with_user_group'
/var/www/miq/vmdb/app/models/miq_queue.rb:425:in `deliver'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:105:in `deliver_queue_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:134:in `deliver_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:152:in `block in do_work'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:146:in `loop'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:146:in `do_work'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:329:in `block in do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:326:in `loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:326:in `do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:153:in `run'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:127:in `start'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:22:in `start_worker'
/var/www/miq/vmdb/app/models/miq_worker.rb:357:in `block in start_runner_via_fork'
/opt/rh/cfme-gemset/gems/nakayoshi_fork-0.0.3/lib/nakayoshi_fork.rb:24:in `fork'
/opt/rh/cfme-gemset/gems/nakayoshi_fork-0.0.3/lib/nakayoshi_fork.rb:24:in `fork'
/var/www/miq/vmdb/app/models/miq_worker.rb:355:in `start_runner_via_fork'
/var/www/miq/vmdb/app/models/miq_worker.rb:349:in `start_runner'
/var/www/miq/vmdb/app/models/miq_worker.rb:396:in `start'
/var/www/miq/vmdb/app/models/miq_worker.rb:266:in `start_worker'
/var/www/miq/vmdb/app/models/miq_worker.rb:153:in `block in sync_workers'
/var/www/miq/vmdb/app/models/miq_worker.rb:153:in `times'
/var/www/miq/vmdb/app/models/miq_worker.rb:153:in `sync_workers'
/var/www/miq/vmdb/app/models/miq_server/worker_management/monitor.rb:53:in `block in sync_workers'
/var/www/miq/vmdb/app/models/miq_server/worker_management/monitor.rb:50:in `each'
/var/www/miq/vmdb/app/models/miq_server/worker_management/monitor.rb:50:in `sync_workers'
/var/www/miq/vmdb/app/models/miq_server.rb:141:in `start'
/var/www/miq/vmdb/app/models/miq_server.rb:233:in `start'
/var/www/miq/vmdb/lib/workers/evm_server.rb:27:in `start'
/var/www/miq/vmdb/lib/workers/evm_server.rb:48:in `start'
/var/www/miq/vmdb/lib/workers/bin/evm_server.rb:4:in `<main>'
[----] I, [2017-11-07T09:56:48.520594 #12387:533130]  INFO -- : MIQ(MiqQueue#delivered) Message id: [370], State: [error], Delivered in [0.003805938] seconds

Comment 2 Ievgen Zapolskyi 2017-11-07 15:03:03 UTC
Created attachment 1349012 [details]
cfme logs

Comment 3 Dave Johnson 2017-11-07 15:16:28 UTC

*** This bug has been marked as a duplicate of bug 1509432 ***


Note You need to log in before you can comment on or make changes to this bug.